diff mbox series

[bug#49101,2/4] gnu: Add ocaml-mparser-re.

Message ID 16c8eb0ab0f0991efa7e4ee982082ad57df5e521.1624042706.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add ocaml-mparser & friends | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 18, 2021, 7:03 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-mparser-re): New variable.
---
 gnu/packages/ocaml.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e90ed8f4e4..eebca5da18 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6768,6 +6768,22 @@  combinator library similar to the Parsec library for Haskell by Daan Leijen and
 the FParsec library for FSharp by Stephan Tolksdorf.")
     ;; With static linking exception.
     (license license:lgpl2.1+)))
+
+(define-public ocaml-mparser-re
+  (package
+    (inherit ocaml-mparser)
+    (name "ocaml-mparser-re")
+    (arguments
+     ;; No tests.
+     '(#:package "mparser-re"
+       #:tests? #f))
+    (propagated-inputs
+     `(("ocaml-mparser" ,ocaml-mparser)
+       ("ocaml-re" ,ocaml-re)))
+    (synopsis "MParser plugin for RE-based regular expressions")
+    (description "This package provides RE-based regular expressions
+support for Mparser.")))
+
 (define-public lablgtk3
   (package
     (name "lablgtk")