diff mbox series

[bug#42985] Add python-dosage.

Message ID 1684791031.5985038.1598110232179@mail.yahoo.com
State Accepted
Headers show
Series [bug#42985] Add python-dosage. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

kasper.andersson--- via Guix-patches" via Aug. 22, 2020, 3:30 p.m. UTC
I'm fairly sure this belongs in python-xyz.scm. The guix import pypi command worked well in this case!
- Hendursaga

Comments

Leo Famulari Aug. 22, 2020, 5:15 p.m. UTC | #1
On Sat, Aug 22, 2020 at 03:30:32PM +0000, Hendur Saga via Guix-patches via wrote:
> I'm fairly sure this belongs in python-xyz.scm. The guix import pypi command worked well in this case!
> - Hendursaga

Perhaps... we don't really have a great place for it. It can always be
moved if we want.

> From 7a0b4a0e993425b8573ae10de63a6ca6f13b03ea Mon Sep 17 00:00:00 2001
> From: Hendursaga <hendursaga@yahoo.com>
> Date: Sat, 22 Aug 2020 15:19:01 +0000
> Subject: [PATCH] gnu: Add python-dosage.
> 
> * gnu/packages/python-xyz.scm (python-dosage): New variable.

Thanks! I renamed the package to 'dosage'. The 'python-' prefix is
really intended for libraries, not user-facing applications.

Pushed as 2183887ba90fc102684277721314d71c556e59c5
diff mbox series

Patch

From 7a0b4a0e993425b8573ae10de63a6ca6f13b03ea Mon Sep 17 00:00:00 2001
From: Hendursaga <hendursaga@yahoo.com>
Date: Sat, 22 Aug 2020 15:19:01 +0000
Subject: [PATCH] gnu: Add python-dosage.

* gnu/packages/python-xyz.scm (python-dosage): New variable.
---
 gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1b1729b43..5be8b8d213 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -83,6 +83,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
+;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1503,6 +1504,43 @@  files are easily readable and they work nicely with version control systems.")
     ;; "fnmatch.py" and "ini.py" are licensed under psfl, the rest is bsd-2.
     (license (list license:bsd-2 license:psfl))))
 
+(define-public python-dosage
+  (package
+    (name "python-dosage")
+    (version "2.17")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "dosage" version))
+       (sha256
+        (base32
+         "0vmxgn9wd3j80hp4gr5iq06jrl4gryz5zgfdd2ah30d12sfcfig0"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python2-backports-functools-lru-cache"
+        ,python2-backports-functools-lru-cache)
+       ("python2-backports-shutil-get-terminal-size"
+        ,python2-backports-shutil-get-terminal-size)
+       ("python-cached-property" ,python-cached-property)
+       ("python-colorama" ,python-colorama)
+       ("python-imagesize" ,python-imagesize)
+       ("python-importlib-metadata" ,python-importlib-metadata)
+       ("python-lxml" ,python-lxml)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-xdist" ,python-pytest-xdist)
+       ("python-responses" ,python-responses)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
+    (home-page "https://github.com/webcomics/dosage")
+    (synopsis "Comic strip downloader and archiver")
+    (description "Dosage is designed to keep a local copy of specific webcomics and other
+picture-based content such as Picture of the Day sites.  With the @command{dosage}
+command-line script you can get the latest strip of a webcomic, catch-up to the last strip
+downloaded, or download a strip for a particular date or index, if possible.")
+    (license license:expat)))
+
 (define-public python-et-xmlfile
   (package
     (name "python-et-xmlfile")
-- 
2.28.0