diff mbox series

[bug#66034,gnome-team,1/3] gnu: glib: fix required.private reference to pcre.

Message ID 1683acded2289fca76c221a997c6735b355f5a27.1694877577.git.vivien@planete-kraus.eu
State New
Headers show
Series Fix qemu | expand

Commit Message

Vivien Kraus Sept. 16, 2023, 9:55 a.m. UTC
* gnu/packages/glib.scm (glib) [#:phases 'patch-pkg-config-files]: Replace the
reference to libpcre-8 to libpcre2-8.
---
 gnu/packages/glib.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler Sept. 16, 2023, 6:52 p.m. UTC | #1
Am Samstag, dem 16.09.2023 um 11:55 +0200 schrieb Vivien Kraus:
> * gnu/packages/glib.scm (glib) [#:phases 'patch-pkg-config-files]:
> Replace the reference to libpcre-8 to libpcre2-8.
> ---
Logic-wise LGTM, but…
>  gnu/packages/glib.scm | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index 8af89d60e0..dcc61802a4 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -449,7 +449,12 @@ (define glib
>                  (("^bindir=.*")
>                   "")
>                  (("=\\$\\{bindir\\}/")
> -                 "=")))))))
> +                 "="))
> +              ;; Update the required.private pcre pkg-config name
> +              (substitute*
> +                  (list (search-input-file outputs
> "lib/pkgconfig/glib-2.0.pc"))
Is there a reason to use a list here?  Also, can we not do this
earlier?
> +                (("libpcre-8")
> +                 "libpcre2-8")))))))
This fits in one line.

Cheers
Vivien Kraus Sept. 17, 2023, 4:07 a.m. UTC | #2
Le samedi 16 septembre 2023 à 20:52 +0200, Liliana Marie Prikler a
écrit :
> Am Samstag, dem 16.09.2023 um 11:55 +0200 schrieb Vivien Kraus:
> > * gnu/packages/glib.scm (glib) [#:phases 'patch-pkg-config-files]:
> > Replace the reference to libpcre-8 to libpcre2-8.
> > ---
> Logic-wise LGTM, but…
> >  gnu/packages/glib.scm | 7 ++++++-
> >  1 file changed, 6 insertions(+), 1 deletion(-)
> > 
> > diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> > index 8af89d60e0..dcc61802a4 100644
> > --- a/gnu/packages/glib.scm
> > +++ b/gnu/packages/glib.scm
> > @@ -449,7 +449,12 @@ (define glib
> >                  (("^bindir=.*")
> >                   "")
> >                  (("=\\$\\{bindir\\}/")
> > -                 "=")))))))
> > +                 "="))
> > +              ;; Update the required.private pcre pkg-config name
> > +              (substitute*
> > +                  (list (search-input-file outputs
> > "lib/pkgconfig/glib-2.0.pc"))
> Is there a reason to use a list here?  Also, can we not do this
> earlier?

I am confused. This is not required at all, glib already points to the
correct libpcre2-8.pc. I don’t know why I thought this would not be the
case; maybe I checked the glib output on the wrong branch.

Anyway, can you just ignore this patch, or do you prefer that I send
the series again, without this one?

Vivien
Liliana Marie Prikler Sept. 17, 2023, 5:19 a.m. UTC | #3
Am Sonntag, dem 17.09.2023 um 06:07 +0200 schrieb Vivien Kraus:
> Le samedi 16 septembre 2023 à 20:52 +0200, Liliana Marie Prikler a
> écrit :
> > Am Samstag, dem 16.09.2023 um 11:55 +0200 schrieb Vivien Kraus:
> > > * gnu/packages/glib.scm (glib) [#:phases 'patch-pkg-config-
> > > files]:
> > > Replace the reference to libpcre-8 to libpcre2-8.
> > > ---
> > Logic-wise LGTM, but…
> > >  gnu/packages/glib.scm | 7 ++++++-
> > >  1 file changed, 6 insertions(+), 1 deletion(-)
> > > 
> > > diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> > > index 8af89d60e0..dcc61802a4 100644
> > > --- a/gnu/packages/glib.scm
> > > +++ b/gnu/packages/glib.scm
> > > @@ -449,7 +449,12 @@ (define glib
> > >                  (("^bindir=.*")
> > >                   "")
> > >                  (("=\\$\\{bindir\\}/")
> > > -                 "=")))))))
> > > +                 "="))
> > > +              ;; Update the required.private pcre pkg-config
> > > name
> > > +              (substitute*
> > > +                  (list (search-input-file outputs
> > > "lib/pkgconfig/glib-2.0.pc"))
> > Is there a reason to use a list here?  Also, can we not do this
> > earlier?
> 
> I am confused. This is not required at all, glib already points to
> the correct libpcre2-8.pc. I don’t know why I thought this would not
> be the case; maybe I checked the glib output on the wrong branch.
> 
> Anyway, can you just ignore this patch, or do you prefer that I send
> the series again, without this one?
Nah, it's fine, I'll skip it.
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 8af89d60e0..dcc61802a4 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -449,7 +449,12 @@  (define glib
                 (("^bindir=.*")
                  "")
                 (("=\\$\\{bindir\\}/")
-                 "=")))))))
+                 "="))
+              ;; Update the required.private pcre pkg-config name
+              (substitute*
+                  (list (search-input-file outputs "lib/pkgconfig/glib-2.0.pc"))
+                (("libpcre-8")
+                 "libpcre2-8")))))))
     (native-inputs
      (list dbus
            gettext-minimal