diff mbox series

[bug#41830] xl2tpd fixes

Message ID 168051591983732@mail.yandex.ru
State Accepted
Headers show
Series [bug#41830] xl2tpd fixes | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ivan Kozlov June 12, 2020, 5:45 p.m. UTC
xl2tpd runs pppd to complete the connection. It also includes some of the Linux headers (and uses fallbacks otherwise).


Diff finished.  Fri Jun 12 20:38:14 2020

Comments

Mathieu Othacehe June 14, 2020, 9:59 a.m. UTC | #1
Привет Иван!

Thanks for this patch :). For future contributions, patches should be
made on top of Guix git repository, using "git format-patch". You should
also follow the guidelines here:
https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html#Sending-a-Patch-Series
in particular, regarding the commit message.

I applied the patch, added your copyright and a commit message.

Thanks,

Mathieu
Ivan Kozlov June 22, 2020, 8:09 a.m. UTC | #2
Hi,

There was a typo in the patch in a compiler flag (-DPPD instead of -DPPPD). Would you please correct that?

14.06.2020, 12:59, "Mathieu Othacehe" <othacehe@gnu.org>:
> Привет Иван!
>
> Thanks for this patch :). For future contributions, patches should be
> made on top of Guix git repository, using "git format-patch". You should
> also follow the guidelines here:
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html#Sending-a-Patch-Series
> in particular, regarding the commit message.
>
> I applied the patch, added your copyright and a commit message.
>
> Thanks,
>
> Mathieu
Mathieu Othacehe June 22, 2020, 8:29 a.m. UTC | #3
Hello,

> There was a typo in the patch in a compiler flag (-DPPD instead of -DPPPD). Would you please correct that?

Oops, fixed.

Thanks,

Mathieu
diff mbox series

Patch

--- /gnu/store/869i2xd7jih9cdcrccwk8rsxycwksjba-guix-module-union/share/guile/site/3.0/gnu/packages/vpn.scm
+++ #<buffer vpn.scm>
@@ -576,9 +576,18 @@ 
      `(#:make-flags (list (string-append "PREFIX=" %output)
                           "CC=gcc")
        #:phases (modify-phases %standard-phases
+                  (add-before 'build 'setup-environment
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (setenv "CFLAGS" (string-append "-DPPD=\""
+                                                      (assoc-ref inputs "ppp")
+                                                      "/sbin/pppd\""))
+                      (setenv "KERNELSRC" (assoc-ref inputs "linux-libre-headers"))
+                      #t))
                   (delete 'configure))  ; no configure script
        #:tests? #f))                    ; no tests provided
-    (inputs `(("libpcap" ,libpcap)))
+    (inputs `(("libpcap" ,libpcap)
+              ("linux-libre-headers" ,linux-libre-headers)
+              ("ppp" ,ppp)))
     (home-page "https://www.xelerance.com/software/xl2tpd/")
     (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
     (description