diff mbox series

[bug#38870] Package ibus-libhangul

Message ID 1627831577962364@sas8-f59b61ed75ea.qloud-c.yandex.net
State Accepted
Headers show
Series [bug#38870] Package ibus-libhangul | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ivan Kozlov Jan. 2, 2020, 10:52 a.m. UTC
It is the Korean input method for IBus. It supports Hangul and Hanja.

---
 gnu/packages/ibus.scm | 58 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)

Comments

Ricardo Wurmus Jan. 3, 2020, 6:23 a.m. UTC | #1
kanichos@yandex.ru writes:

> It is the Korean input method for IBus. It supports Hangul and Hanja.

Thank you.

I split this into two commits:

94b8fe80419b835dbcab989a48d272c2bb65798f for libhangul
30208c1078485f0392f476f5d89693f6d338016f for ibus-libhangul

I changed the description of libhangul and used the version variable in
the source URI.  I also changed the indentation and added a copyright
line for you.
Ivan Kozlov Jan. 3, 2020, 9:21 a.m. UTC | #2
Note that the source URI is unique anyway. The number in front of ‘libhangul’ is unique. Is it not misleading to compose it from the version variable? Also, apparently, there has not been a new release for ten years, despite development continuing on GitHub.

Also it seems that the IBus engine is actually called ibus-hangul.

03.01.2020, 10:02, "Ricardo Wurmus" <rekado@elephly.net>:
> kanichos@yandex.ru writes:
>
>>  It is the Korean input method for IBus. It supports Hangul and Hanja.
>
> Thank you.
>
> I split this into two commits:
>
> 94b8fe80419b835dbcab989a48d272c2bb65798f for libhangul
> 30208c1078485f0392f476f5d89693f6d338016f for ibus-libhangul
>
> I changed the description of libhangul and used the version variable in
> the source URI. I also changed the indentation and added a copyright
> line for you.
>
> --
> Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 7daefde021..b2b75f5ba3 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -692,3 +692,61 @@  input methods as well as those for Chinese dialects.  It has the ability to
 compose phrases and sentences intelligently and provide very accurate
 traditional Chinese output.")
     (license gpl3+)))
+
+(define-public libhangul
+  (package
+    (name "libhangul")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri "http://kldp.net/hangul/release/3442-libhangul-0.1.0.tar.gz")
+       (sha256
+        (base32
+         "0ni9b0v70wkm0116na7ghv03pgxsfpfszhgyj3hld3bxamfal1ar"))))
+    (build-system gnu-build-system)
+    (home-page "https://github.com/libhangul/libhangul")
+    (synopsis
+     "A library to support hangul input method logic")
+    (description
+     "A library to support hangul input method logic, hanja dictionary and small hangul character classification.")
+    (license lgpl2.1+)))
+
+(define-public ibus-libhangul
+  (package
+    (name "ibus-libhangul")
+    (version "1.5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/libhangul/ibus-hangul/releases/download/" version "/ibus-hangul-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1400ba2p34vr9q285lqvjm73f6m677cgfdymmjpiwyrjgbbiqrjy"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'install 'wrap
+                    (lambda* (#:key inputs outputs #:allow-other-keys)
+                      (wrap-program (string-append (assoc-ref outputs "out") "/libexec/ibus-setup-hangul")
+                        `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
+                        `("LD_LIBRARY_PATH" ":" prefix (,(string-append (assoc-ref inputs "libhangul") "/lib")))
+                        `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
+                      #t)))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")))
+    (inputs
+     `(("ibus" ,ibus)
+       ("glib" ,glib)
+       ("python-pygobject" ,python-pygobject)
+       ("gtk+" ,gtk+)
+       ("libhangul" ,libhangul)
+       ("python" ,python)))
+    (home-page "https://github.com/libhangul/ibus-hangul")
+    (synopsis
+     "The hangul engine for IBus")
+    (description
+     "ibus-hangul is a Korean input method engine for IBus.")
+    (license gpl2+)))