diff mbox series

[bug#61031] Add emacs-kodi-remote.

Message ID 1619463260.211138834.1674823418016.JavaMail.zimbra@free.fr
State New
Headers show
Series [bug#61031] Add emacs-kodi-remote. | expand

Commit Message

Matthieu Lemerre Jan. 27, 2023, 12:43 p.m. UTC
Thanks for all the comments! Here is an updated patch addressing everything.

You were right about the problem that it did not compile; I did not understand that I had to to make
before ./pre-inst-env guix build emacs-kodi-remote. I think I properly tested it now.

Matthieu

---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Jan. 27, 2023, 10:04 p.m. UTC | #1
Hello,

racin@free.fr writes:

> You were right about the problem that it did not compile; I did not understand that I had to to make
> before ./pre-inst-env guix build emacs-kodi-remote. I think I properly
> tested it now.

Great. I added a commit message and applied your patch, with the changes below.

> +    (package
> +      (name "emacs-kodi-remote")
> +      (version (git-version "0" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/spiderbit/kodi-remote.el.git")

I removed ".git" suffix
> +                      (commit commit)))

I added

  (file-name (git-file-name name version))

here

> +                (sha256
> +                 (base32
> +                  "1gck7lvqxcr9ikrzlpvcf4408cq6i4s8ijgb0kdsbkfzv0w86934"))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs (list emacs-f emacs-json-mode emacs-let-alist emacs-request))

I added a newline character after "propagated-inputs".
> +      (home-page "http://github.com/spiderbit/kodi-remote.el")
> +      (synopsis "Remote Control for Kodi")

Control -> control

Regards,
Matthieu Lemerre Jan. 27, 2023, 10:10 p.m. UTC | #2
> Great. I added a commit message and applied your patch, with the changes below.

Great! I'll try to be more careful next time!

> I removed ".git" suffix

You had mentionned it, sorry.

> I added   (file-name (git-file-name name version)) 

This I didn't know.

> Control -> control

Oups.

Regards,

Matthieu
Nicolas Goaziou Jan. 27, 2023, 10:16 p.m. UTC | #3
racin@free.fr writes:

>> I added   (file-name (git-file-name name version)) 

> This I didn't know.

If you run

  ./pre-inst-env guix lint emacs-kodi-remote

you will get something like

  emacs-kodi-remote@0-0.f5e9320: the source file name should contain the package name
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c2be7eac57..0c832110a0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26708,6 +26708,30 @@  (define-public emacs-mpdel
 stored playlists.")
     (license license:gpl3+)))
 
+
+(define-public emacs-kodi-remote
+  (let ((commit "f5e932036c16e2b61a63020e006fc601e38d181e")
+        (revision "0"))
+    (package
+      (name "emacs-kodi-remote")
+      (version (git-version "0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/spiderbit/kodi-remote.el.git")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1gck7lvqxcr9ikrzlpvcf4408cq6i4s8ijgb0kdsbkfzv0w86934"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-f emacs-json-mode emacs-let-alist emacs-request))
+      (home-page "http://github.com/spiderbit/kodi-remote.el")
+      (synopsis "Remote Control for Kodi")
+      (description
+       "This package provides a major mode to remote control Kodi
+instances (play/pause, volume control, media selection, etc.).")
+      (license license:gpl3+))))
+
 (define-public emacs-navigel
   (package
     (name "emacs-navigel")