diff mbox series

[bug#61678,v4,2/2] gnu: Add smlsharp.

Message ID 15a07e5595ea1fda4bbb0825375926898140c9c5.1704106646.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#61678,v4,1/2] gnu: Add massivethreads. | expand

Commit Message

gemmaro Jan. 1, 2024, 10:57 a.m. UTC
* gnu/packages/sml.scm (smlsharp): New variable.

Change-Id: I3418d7219d88653432f16e6bca3e4aa6e7467bd8
---
 gnu/packages/sml.scm | 56 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sml.scm b/gnu/packages/sml.scm
index 368abf6cfa..8d5373328d 100644
--- a/gnu/packages/sml.scm
+++ b/gnu/packages/sml.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2021, 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,12 +22,17 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages sml)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages lesstif)
   #:use-module (gnu packages libffi)
+  #:use-module (gnu packages llvm)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages parallel)
   #:use-module (gnu packages xorg)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
@@ -340,3 +346,53 @@  (define-public smlnj
     (license (license:fsf-free
                "https://www.smlnj.org/license.html"
                "https://www.gnu.org/licenses/license-list#StandardMLofNJ"))))
+
+(define-public smlsharp
+  (package
+    (name "smlsharp")
+    (version "4.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/smlsharp/smlsharp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0cwpp4azkr79vf3c0w3g3zxv1rdcbi4gs7kp80b7aa1b5cqv04bj"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:parallel-build? #t
+      #:parallel-tests? #t
+      #:test-target "test"
+      #:phases #~(modify-phases %standard-phases
+                   ;; NOTE: Needed for running SML# executables
+                   (add-after 'install 'wrap-programs
+                     (lambda* (#:key inputs outputs #:allow-other-keys)
+                       (let ((out (assoc-ref outputs "out"))
+                             (libs (map (lambda (name)
+                                          (string-append (assoc-ref inputs
+                                                                    name)
+                                                         "/lib"))
+                                        '("gmp" "massivethreads" "glibc"))))
+                         (with-directory-excursion (string-append out "/bin")
+                           (for-each (lambda (file)
+                                       (wrap-program (basename file)
+                                         `("LIBRARY_PATH" prefix
+                                           ,libs)) #t)
+                                     (find-files ".")))))))))
+    (inputs (list llvm-11 gmp massivethreads glibc bash-minimal))
+    (home-page "https://smlsharp.github.io/en/")
+    (synopsis "New language in the Standard ML family")
+    (description
+     "SML# is a new generation of the Standard ML family.  The main features
+of SML# include the following:
+@itemize
+@item record polymorphism
+@item integration with SQL
+@item interoperability with C
+@item separate compilation and linking
+@item multithread support
+@end itemize")
+    (license license:expat)))