diff mbox series

[bug#39626] Geary with Gspell fix

Message ID 1581808346.699.0@riseup.net
State Accepted
Headers show
Series [bug#39626] Geary with Gspell fix | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Csepp Feb. 15, 2020, 11:12 p.m. UTC
Here is that Geary package I said I'd send yesterday and a patch for 
Gspell that turns on the necessary --enable-vala flag, since Geary 
depends on its VAPI.

I'm sending this patch from it, so I hope it's formatting it as it 
should...

Comments

Ludovic Courtès March 18, 2020, 10:57 a.m. UTC | #1
Hi!

raingloom@riseup.net skribis:

>>From ae635776361622f37aa02975b0f4e4698015ef84 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@protonmail.com>
> Date: Sun, 9 Feb 2020 04:18:04 +0100
> Subject: [PATCH 2/2] gnu: geary: new package (version 3.34.1)
>
> ---
>  gnu/packages/gnome.scm | 98 ++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 98 insertions(+)

[...]

>>From c2749f9c10d3b424b3470be5d9ea680886fac0b2 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@protonmail.com>
> Date: Sun, 16 Feb 2020 00:00:35 +0100
> Subject: [PATCH 1/2] gnu: gspell: --enable-vala for VAPI (for geary)
>
> ---
>  gnu/packages/gnome.scm | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)

Finally applied both patches!

I took the liberty to adjust the Geary patch to avoid ‘regexp-quote’ and
the non-literal strings in ‘substitute*’.

Thanks,
Ludo’.
diff mbox series

Patch

From c2749f9c10d3b424b3470be5d9ea680886fac0b2 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@protonmail.com>
Date: Sun, 16 Feb 2020 00:00:35 +0100
Subject: [PATCH 1/2] gnu: gspell: --enable-vala for VAPI (for geary)

---
 gnu/packages/gnome.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 014b68f54f..9fb5db4f87 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8879,7 +8879,8 @@  that support the Assistive Technology Service Provider Interface (AT-SPI).")
               (patches (search-patches "gspell-dash-test.patch"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     '(#:phases
+     '(#:configure-flags (list "--enable-vala")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'check 'pre-check
            (lambda* (#:key inputs #:allow-other-keys)
@@ -8904,6 +8905,7 @@  that support the Assistive Technology Service Provider Interface (AT-SPI).")
      `(("glib" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("pkg-config" ,pkg-config)
+       ("vala" ,vala) ;;for VAPI
        ("xmllint" ,libxml2)
 
        ;; For tests.
-- 
2.25.0