[bug#34647] gnu: python-petsc4py: Update to 10.3.1.

Message ID 1551101169-7293-1-git-send-email-pgarlick@tourbillion-technology.com
State Accepted
Commit 758439cf4b20851d25c1d72d289cc6d4556ccda2
Headers show
Series [bug#34647] gnu: python-petsc4py: Update to 10.3.1. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Paul Garlick Feb. 25, 2019, 1:26 p.m. UTC
* gnu/packages/maths.scm (python-petsc4py): Update to 10.3.1.
---
 gnu/packages/maths.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Feb. 26, 2019, 1:55 a.m. UTC | #1
On Mon, Feb 25, 2019 at 01:26:09PM +0000, Paul Garlick wrote:
> * gnu/packages/maths.scm (python-petsc4py): Update to 10.3.1.

I tested this update by building fenics on top of it. On my x86-63
machine, it failed as below. Is this expected or a reason to block the
python-petsc4py update?

------
[ 95%] Building CXX object dolfin/CMakeFiles/dolfin.dir/nls/TAOLinearBoundSolver.cpp.o
cd /tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/build/dolfin && /gnu/store/n2p1zs14y89lwkg9da68y12pc10c6sw9-gcc-5.5.0/bin/c++  -DDOLFIN_VERSION=\"2018.1.0\" -DHAS_CHOLMOD -DHAS_HDF5 -DHAS_MPI -DHAS_PETSC -DHAS_SCOTCH -DHAS_SLEPC -DHAS_SUNDIALS -DHAS_UMFPACK -DHAS_ZLIB -DNDEBUG -Ddolfin_EXPORTS -I/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/fenics-project-dolfin-948dc42cc4e0 -I/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/build -I/gnu/store/9ghap4fk37lqzpcxplrswvg0yfmwm64x-sundials-openmpi-3.1.1/include -isystem /gnu/store/4vciqisw09sfpb3dc5nshynwgrv7sh1d-python-fenics-ffc-2018.1.0/lib/python3.7/site-packages/ffc/backends/ufc -isystem /gnu/store/kd4byfi7fyck8i0qy298ghrr0ig8cxay-eigen-3.3.5/include/eigen3 -isystem /gnu/store/gw08kjck9zpib5v2vc3jdrws5a838gpd-hdf5-parallel-openmpi-1.8.21/include -isystem /gnu/store/2y704qn8mjljnmswf87dky0nzzlbld1d-suitesparse-4.5.5/include -isystem /gnu/store/xbbiqkjdl8xs018qk217p7fqqgnzdk67-pt-scotch32-6.0.6/include -isystem /gnu/store/nq4lsyipmfb0q7g26ra45rwwqrh3x8zw-zlib-1.2.11/include -isystem /gnu/store/lpd53a5zszm9mzzn68i7a1cwcf0nymvy-openmpi-4.0.0/include -isystem /gnu/store/pz22lgiw476i9fla6ds5f1shchndk7ny-boost-1.69.0/include  -O2 -g -DNDEBUG -fPIC   -std=c++11 -o CMakeFiles/dolfin.dir/nls/TAOLinearBoundSolver.cpp.o -c /tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/fenics-project-dolfin-948dc42cc4e0/dolfin/nls/TAOLinearBoundSolver.cpp
/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/fenics-project-dolfin-948dc42cc4e0/dolfin/nls/PETScSNESSolver.cpp:51:64: error: ‘SNESTEST’ was not declared in this scope
     {"test",         {"Tool to verify Jacobian approximation", SNESTEST}},
                                                                ^
/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/fenics-project-dolfin-948dc42cc4e0/dolfin/nls/PETScSNESSolver.cpp:68:56: error: could not convert ‘{{"default", {"default SNES method", ""}}, {"newtonls", {"Line search method", "newtonls"}}, {"newtontr", {"Trust region method", "newtontr"}}, {"test", {"Tool to verify Jacobian approximation", <expression error>}}, {"ngmres", {"Nonlinear generalised minimum residual method", "ngmres"}}, {"nrichardson", {"Richardson nonlinear method (Picard iteration)", "nrichardson"}}, {"vinewtonrsls", {"Reduced space active set solver method (for bounds)", "vinewtonrsls"}}, {"vinewtonssls", {"Reduced space active set solver method (for bounds)", "vinewtonssls"}}, {"qn", {"Limited memory quasi-Newton", "qn"}}, {"ncg", {"Nonlinear conjugate gradient method", "ncg"}}, {"fas", {"Full Approximation Scheme nonlinear multigrid method", "fas"}}, {"nasm", {"Nonlinear Additive Schwartz", "nasm"}}, {"anderson", {"Anderson mixing method", "anderson"}}, {"aspin", {"Additive-Schwarz Preconditioned Inexact Newton", "aspin"}}, {"ms", {"Multistage smoothers", "ms"}}}’ from ‘<brace-enclosed initializer list>’ to ‘const std::map<std::__cxx11::basic_string<char>, std::pair<std::__cxx11::basic_string<char>, const char* const> >’
     {"ms",           {"Multistage smoothers", SNESMS}} };
                                                        ^
[ 95%] Building CXX object dolfin/CMakeFiles/dolfin.dir/parameter/GlobalParameters.cpp.o
cd /tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/build/dolfin && /gnu/store/n2p1zs14y89lwkg9da68y12pc10c6sw9-gcc-5.5.0/bin/c++  -DDOLFIN_VERSION=\"2018.1.0\" -DHAS_CHOLMOD -DHAS_HDF5 -DHAS_MPI -DHAS_PETSC -DHAS_SCOTCH -DHAS_SLEPC -DHAS_SUNDIALS -DHAS_UMFPACK -DHAS_ZLIB -DNDEBUG -Ddolfin_EXPORTS -I/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/fenics-project-dolfin-948dc42cc4e0 -I/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/build -I/gnu/store/9ghap4fk37lqzpcxplrswvg0yfmwm64x-sundials-openmpi-3.1.1/include -isystem /gnu/store/4vciqisw09sfpb3dc5nshynwgrv7sh1d-python-fenics-ffc-2018.1.0/lib/python3.7/site-packages/ffc/backends/ufc -isystem /gnu/store/kd4byfi7fyck8i0qy298ghrr0ig8cxay-eigen-3.3.5/include/eigen3 -isystem /gnu/store/gw08kjck9zpib5v2vc3jdrws5a838gpd-hdf5-parallel-openmpi-1.8.21/include -isystem /gnu/store/2y704qn8mjljnmswf87dky0nzzlbld1d-suitesparse-4.5.5/include -isystem /gnu/store/xbbiqkjdl8xs018qk217p7fqqgnzdk67-pt-scotch32-6.0.6/include -isystem /gnu/store/nq4lsyipmfb0q7g26ra45rwwqrh3x8zw-zlib-1.2.11/include -isystem /gnu/store/lpd53a5zszm9mzzn68i7a1cwcf0nymvy-openmpi-4.0.0/include -isystem /gnu/store/pz22lgiw476i9fla6ds5f1shchndk7ny-boost-1.69.0/include  -O2 -g -DNDEBUG -fPIC   -std=c++11 -o CMakeFiles/dolfin.dir/parameter/GlobalParameters.cpp.o -c /tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/fenics-project-dolfin-948dc42cc4e0/dolfin/parameter/GlobalParameters.cpp
make[2]: *** [dolfin/CMakeFiles/dolfin.dir/build.make:2770: dolfin/CMakeFiles/dolfin.dir/nls/PETScSNESSolver.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:276: dolfin/CMakeFiles/dolfin.dir/all] Error 2
make[1]: Leaving directory '/tmp/guix-build-fenics-dolfin-2018.1.0.post1.drv-0/build'
make: *** [Makefile:144: all] Error 2
Backtrace:
           4 (primitive-load "/gnu/store/fvv87kxqx1lnw75y2qyqq5srwm7…")
In ice-9/eval.scm:
   191:35  3 (_ _)
In srfi/srfi-1.scm:
   863:16  2 (every1 #<procedure 763720 at /gnu/store/6bwkbm3a80v0x…> …)
In /gnu/store/6bwkbm3a80v0xab5qsicij7bjvmn5yna-module-import/guix/build/gnu-build-system.scm:
   799:28  1 (_ _)
In /gnu/store/6bwkbm3a80v0xab5qsicij7bjvmn5yna-module-import/guix/build/utils.scm:
    616:6  0 (invoke _ . _)

/gnu/store/6bwkbm3a80v0xab5qsicij7bjvmn5yna-module-import/guix/build/utils.scm:616:6: In procedure invoke:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "make" arguments: ("-j" "4") exit-status: 2 term-signal: #f stop-signal: #f] 56df80>)'.
builder for `/gnu/store/znvp5a2xnqvzgg9sdbz4wc67wgk3ilrv-fenics-dolfin-2018.1.0.post1.drv' failed with exit code 1
build of /gnu/store/znvp5a2xnqvzgg9sdbz4wc67wgk3ilrv-fenics-dolfin-2018.1.0.post1.drv failed
View build log at '/var/log/guix/drvs/zn/vp5a2xnqvzgg9sdbz4wc67wgk3ilrv-fenics-dolfin-2018.1.0.post1.drv.bz2'.
cannot build derivation `/gnu/store/v152180dwfgwjk6bpxxf0bni8dcd013n-fenics-2018.1.0.post1.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/v152180dwfgwjk6bpxxf0bni8dcd013n-fenics-2018.1.0.post1.drv' failed
------
Paul Garlick Feb. 26, 2019, 3:06 p.m. UTC | #2
Hi Leo,

> I tested this update by building fenics on top of it. On my x86-63
> machine, it failed as below. Is this expected or a reason to block
> the python-petsc4py update?

Thank you for doing the fenics test too.  

I have fixed the build problem for fenics-dolfin in patch #34668.

These patches for python-petsc4py and fenics-dolfin have been made 
necessary by the recent update of the PETSc dependency.  Essentially,
a symbol that used to be referenced in these packages is no longer
made available by PETSc.

Best regards,

Paul.
Leo Famulari Feb. 26, 2019, 10:26 p.m. UTC | #3
On Tue, Feb 26, 2019 at 03:06:03PM +0000, Paul Garlick wrote:
> Hi Leo,
> 
> > I tested this update by building fenics on top of it. On my x86-63
                                                                     ^
Oops, silly typo ----------------------------------------------------|

> > machine, it failed as below. Is this expected or a reason to block
> > the python-petsc4py update?
> 
> Thank you for doing the fenics test too.  
> 
> I have fixed the build problem for fenics-dolfin in patch #34668.

Great!

> These patches for python-petsc4py and fenics-dolfin have been made 
> necessary by the recent update of the PETSc dependency.  Essentially,
> a symbol that used to be referenced in these packages is no longer
> made available by PETSc.

Okay, I've pushed the python-petsc4py update as
758439cf4b20851d25c1d72d289cc6d4556ccda2

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 74554e2..a39323e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1797,14 +1797,14 @@  scientific applications modeled by partial differential equations.")
 (define-public python-petsc4py
   (package
     (name "python-petsc4py")
-    (version "3.10.0")
+    (version "3.10.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "petsc4py" version))
         (sha256
           (base32
-            "0ch3g6dsvxl7qi984fcssv7cxfbif4bw04gkvxl2l1b8wrmvrm25"))))
+            "094hcnran0r2z1wlvmjswsz3ski1m9kqrl5l0ax8jjhnk55x0flh"))))
     (build-system python-build-system)
     (arguments
      `(#:phases