diff mbox series

[bug#39896,04/14] gnu: Add kblog.

Message ID 14d8c378edf4294394c81a0e5273b8d7bba5f5e4.1583313373.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#39896,01/14] gnu: Add libksieve. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Hartmut Goebel March 4, 2020, 9:21 a.m. UTC
* gnu/packages/kde-pim.scm (kblog): New variable.
---
 gnu/packages/kde-pim.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 58bd67a653..d4209ac7c7 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -376,6 +376,40 @@  Akonadi PIM data server.  It uses Xapian for indexing and querying.")
 calendar data.")
     (license  license:lgpl2.0+)))
 
+(define-public kblog
+  (package
+    (name "kblog")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/kblog-" version ".tar.xz"))
+       (sha256
+        (base32 "0r3ik3df444kzg2mnzckkh4kk6v08zil1f26dwmxsslsqw9hl0vv"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kcalendarcore" ,kcalendarcore)
+       ("kcoreaddons" ,kcoreaddons)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("kxmlrpcclient" ,kxmlrpcclient)
+       ("qtbase" ,qtbase)
+       ("syndication" ,syndication)))
+    ;; Note: Some tests take up to 90 sec.
+    (home-page "https://cgit.kde.org/kblog.git")
+    (synopsis "Client-side support library for web application remote blogging
+APIs")
+    (description "KBlog is a library for calling functions on Blogger 1.0,
+MetaWeblog, MovableType and GData compatible blogs.  It calls the APIs using
+KXmlRpcClient and Syndication.  It supports asynchronous sending and fetching
+of posts and, if supported on the server, multimedia files.  Almost every
+modern blogging web application that provides an XML data interface supports
+one of the APIs mentioned above.")
+    (license license:lgpl2.0+)))
+
 (define-public kcalutils
   (package
     (name "kcalutils")