[bug#76746,v2,09/13] gnu: Add python-soundcloud-v2.

Message ID 14207ba0d709b563395478e8ee16af5be096b0d7.1741702573.git.45mg.writes@gmail.com
State New
Headers
Series None |

Commit Message

45mg March 11, 2025, 2:23 p.m. UTC
  * gnu/packages/python-web.scm (python-soundcloud-v2): New variable.

Change-Id: I6126d879bb6f44155e61e6eaed2cc9fe51c4103e
---
 gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index dec3b7d7ba..ff8469fd61 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -10720,6 +10720,31 @@  (define-public python-syncedlyrics
 music.")
     (license license:expat)))
 
+(define-public python-soundcloud-v2
+  (package
+    (name "python-soundcloud-v2")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "soundcloud-v2" version))
+       (sha256
+        (base32 "0hw2wxrg0rgj0x1ccy0lz0rws39byzs1din1573rxz0gdha169a6"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-poetry-core python-setuptools python-wheel))
+    (propagated-inputs (list python-dacite
+                             python-dateutil
+                             python-rapidfuzz
+                             python-requests))
+    (arguments
+     (list #:tests? #f))  ;Tests require network
+    (home-page "https://github.com/7x11x13/soundcloud.py")
+    (synopsis "Unofficial wrapper for internal v2 SoundCloud API")
+    (description
+     "A Python wrapper for some of the internal v2 SoundCloud API (read/GET
+only methods).  Does not require an API key.")
+    (license license:expat)))
+
 (define-public python-whatthepatch
   (package
     (name "python-whatthepatch")