diff mbox series

[bug#35518] gnu: guile-pfds bugfix

Message ID 141212fdb5356cbf7ad955a70bc26379@hyper.dev
State Accepted
Headers show
Series [bug#35518] gnu: guile-pfds bugfix | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amirouche May 1, 2019, 12:52 a.m. UTC
I am not sure how to handle this case.

Comments

Ricardo Wurmus May 1, 2019, 6:20 a.m. UTC | #1
Hi amirouche,

> I am not sure how to handle this case.

Is this fix available upstream?  Has this been reported upstream?  In
either case there should be a note about the upstream status of this
change.

I’d prefer not to add a patch file here but to add a build phase after
unpack that uses substitute* to patch the file.

--
Ricardo
Amirouche May 1, 2019, 10:58 a.m. UTC | #2
On 2019-05-01 08:20, Ricardo Wurmus wrote:
> Hi amirouche,
> 
>> I am not sure how to handle this case.
> 
> Is this fix available upstream?

It is not available upstream. The maintainer is unresponsive for several 
months (years?).

> Has this been reported upstream?

Yes at https://github.com/ijp/pfds/pull/6

> In either case there should be a note about the upstream status of this
> change.

I think pfds would need a new maintainer.

> I’d prefer not to add a patch file here but to add a build phase after
> unpack that uses substitute* to patch the file.

Ok I will do that.
Amirouche June 26, 2019, 1:47 a.m. UTC | #3
I had no response from Ian J. Price the original maintainer of pfds.

Can some else try to reach him?
Jack Hill June 6, 2020, 3:33 a.m. UTC | #4
I came across this bug today. It seems like upstream activity on 
guile-pfds is dorment, unfortunately, so it would be good to get this fix 
in Guix. Perhaps all the needs to be done is directing readers to the 
proposed fix at the upstream repository.

Best,
Jack
diff mbox series

Patch

From 9f3ed8f52957c61bd05da50b02e3a43a976facc3 Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche+dev@hyper.dev>
Date: Wed, 1 May 2019 02:47:10 +0200
Subject: [PATCH] gnu: guile-pfds bugfix

* gnu/packages/guile-xyz.scm (guile-pfds)[source]: Add patch.
* gnu/packages/patches/guile-pfds-typofix.patch: Add it.
---
 gnu/packages/guile-xyz.scm                    |  6 +++--
 gnu/packages/patches/guile-pfds-typofix.patch | 25 +++++++++++++++++++
 2 files changed, 29 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/guile-pfds-typofix.patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index d7866719b4..efdcd0fc11 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -626,7 +626,7 @@  using Guile's foreign function interface.")
 (define-public guile-pfds
   (package
     (name "guile-pfds")
-    (version "0.3")
+    (version "0.3.1")
     (home-page "https://github.com/ijp/pfds")
     (source (origin
               (method git-fetch)
@@ -636,7 +636,9 @@  using Guile's foreign function interface.")
               (sha256
                (base32
                 "19y33wg94pf0n98dkfqd1zbw93fgky4sawxsxl6s3vyqwl0yi5vh"))
-              (file-name (string-append name "-" version "-checkout"))))
+              (file-name (string-append name "-" version "-checkout"))
+              (patches
+               (search-patches "guile-pfds-typofix.patch"))))
     (build-system guile-build-system)
     (arguments
      '(#:source-directory "src"
diff --git a/gnu/packages/patches/guile-pfds-typofix.patch b/gnu/packages/patches/guile-pfds-typofix.patch
new file mode 100644
index 0000000000..05fdc46e2b
--- /dev/null
+++ b/gnu/packages/patches/guile-pfds-typofix.patch
@@ -0,0 +1,25 @@ 
+From 0825c9daa90e1f0517bfe98e465fb5d54ab394ac Mon Sep 17 00:00:00 2001
+From: Amirouche <amirouche+dev@hyper.dev>
+Date: Wed, 1 May 2019 01:11:51 +0200
+Subject: [PATCH] hamts: typofix s/vector/trie/
+
+---
+ hamts.sls | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/hamts.sls b/hamts.sls
+index 8746141..a5310d2 100644
+--- a/hamts.sls
++++ b/hamts.sls
+@@ -307,7 +307,7 @@
+ 
+ (define (fold combine initial vector)
+   (define (handle-subtrie trie accum)
+-    (vector-fold dispatch accum (subtrie-vector vector)))
++    (vector-fold dispatch accum (subtrie-vector trie)))
+ 
+   (define (handle-leaf leaf accum)
+     (combine (leaf-key leaf) (leaf-value leaf) accum))
+-- 
+2.19.1
+
-- 
2.19.1