diff mbox series

[bug#64408] gnu: Add privacybrowser.

Message ID 14031887.Zlvoba7YER@soren-desktop
State New
Headers show
Series [bug#64408] gnu: Add privacybrowser. | expand

Commit Message

Soren Stoutner Oct. 17, 2023, 6:01 p.m. UTC
Privacy Browser 0.5 has been released.  Attached is an updated patch.
diff mbox series

Patch

From d5358a483d55c54573b336b297ae3728fbcff029 Mon Sep 17 00:00:00 2001
Message-Id: <d5358a483d55c54573b336b297ae3728fbcff029.1697564327.git.soren@stoutner.com>
From: Soren Stoutner <soren@stoutner.com>
Date: Tue, 17 Oct 2023 10:30:53 -0700
Subject: [PATCH] gnu: Add Privacy Browser.

* gnu/packages/privacybrowser.scm: New file.
---
 gnu/packages/privacybrowser.scm | 58 +++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
 create mode 100644 gnu/packages/privacybrowser.scm

diff --git a/gnu/packages/privacybrowser.scm b/gnu/packages/privacybrowser.scm
new file mode 100644
index 0000000000..6ae7247ed0
--- /dev/null
+++ b/gnu/packages/privacybrowser.scm
@@ -0,0 +1,58 @@ 
+;;; Privacy Browser PC --- A web browser that respects your privacy.
+;;; Copyright © 2023 Soren Stoutner <soren@stoutner.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages privacybrowser)
+  #:use-module (guix build-system qt)
+  #:use-module (guix download)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (gnu packages kde-frameworks)
+  #:use-module (gnu packages kde-systemtools)
+  #:use-module (gnu packages qt))
+
+(define-public privacybrowser
+  (package
+    (name "privacybrowser")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://download.stoutner.com/privacybrowser-pc/privacybrowser-"
+             version ".tar.xz"))
+       (sha256
+        (base32 "1rywfmmw535bs0h3i4yrif3xmz2a4flp04bmhqdlbri4h1pk7x2y"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list breeze-icons
+                  kcrash
+                  kdbusaddons
+                  khelpcenter
+                  ki18n
+                  kio
+                  knotifications
+                  qtsvg-5
+                  qtwebengine-5))
+    (home-page "https://www.stoutner.com/privacy-browser-pc/")
+    (synopsis "Web browser that respects your privacy")
+    (description
+     "Privacy Browser is a web browser based on Qt WebEngine
+with a focus on privacy and security.  Features like JavaScript and
+cookies are disabled by default but are easy to automatically enable
+on-the-fly or by domain.")
+    (license gpl3+)))

base-commit: b437896e87a51cc610388d4c462893652dd773e6
-- 
2.39.2