diff mbox series

[bug#67354,gnome-team,2/2] gnu: grilo-plugins: Update to 0.3.16.

Message ID 13fb95c952f44cc2ed5bbafb9e4bb8dfc2923d90.1700606853.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#67354,gnome-team,1/2] gnu: grilo: Update to 0.3.16. | expand

Commit Message

Vivien Kraus Nov. 21, 2023, 10:46 p.m. UTC
* gnu/packages/gnome.scm (grilo-plugins): Update to 0.3.16.
[arguments]: Convert to a list of G-Expressions.
[home-page]: Update.

Change-Id: I20876f9b594f8d33f2c85e313656791fb3b6812b
---
 gnu/packages/gnome.scm | 33 +++++++++++++++++----------------
 1 file changed, 17 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9cef622869..eb2df3c44a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6559,7 +6559,7 @@  (define-public grilo
 (define-public grilo-plugins
   (package
     (name "grilo-plugins")
-    (version "0.3.15")
+    (version "0.3.16")
     (source
      (origin
        (method url-fetch)
@@ -6567,7 +6567,7 @@  (define-public grilo-plugins
                            (version-major+minor version) "/"
                            name "-" version ".tar.xz"))
        (sha256
-        (base32 "0cxbxg7i9qd1pyfjj7c15x9lawvaw5608jk2apcrac7rakcw6645"))))
+        (base32 "1jydhk822sigyda3mswn59j9s01dy81f553382i8nsvcb2z4svzy"))))
     (build-system meson-build-system)
     (native-inputs
      (list gettext-minimal
@@ -6593,20 +6593,21 @@  (define-public grilo-plugins
            tracker
            tracker-miners))
     (arguments
-     `(#:glib-or-gtk? #t
-       ;;Disable lua-factory as it needs missing dependencies
-       #:configure-flags '("-Denable-lua-factory=no")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'set-shell
-           (lambda _
-             (setenv "SHELL" (which "bash"))))
-         ;; Disable the tracker test that requires the UPower daemon.
-         (add-before 'configure 'fix-tests
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "tests/tracker3/meson.build"
-               (("'test_tracker3'.*") "")))))))
-    (home-page "https://live.gnome.org/Grilo")
+     (list
+      #:glib-or-gtk? #t
+      ;;Disable lua-factory as it needs missing dependencies
+      #:configure-flags #~'("-Denable-lua-factory=no")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'set-shell
+            (lambda _
+              (setenv "SHELL" (which "bash"))))
+          ;; Disable the tracker test that requires the UPower daemon.
+          (add-before 'configure 'fix-tests
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* "tests/tracker3/meson.build"
+                (("'test_tracker3'.*") "")))))))
+    (home-page "https://wiki.gnome.org/Projects/Grilo")
     (synopsis "Plugins for the Grilo media discovery library")
     (description
      "Grilo is a framework focused on making media discovery and browsing easy