diff mbox series

[bug#46653] Make some changes to Profanity stuff (v2)

Message ID 13de1bda-3aa8-684c-3294-f6c37ab93cce@raghavgururajan.name
State Accepted
Headers show
Series [bug#46653] Make some changes to Profanity stuff (v2) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Feb. 23, 2021, 5:08 p.m. UTC

Comments

Leo Prikler Feb. 23, 2021, 5:28 p.m. UTC | #1
Hi Raghav,

Am Dienstag, den 23.02.2021, 12:08 -0500 schrieb Raghav Gururajan:
> +    (arguments
> +     `(#:tests? #f         ; 
> https://github.com/profanity-im/libmesode/issues/20
> +       #:configure-flags
> +       (list
> +        "--disable-static")))
There is just one failing test here.  If there's really no way around
it, disable that one, but try to investigate the link error first.

> +    (arguments
> +     `(#:tests? #f         ; 
> https://github.com/strophe/libstrophe/issues/175
> +       #:configure-flags
> +       (list
> +        "--disable-static")))
Since this issue is related, we should really get to the roots of it. 
Let's hope for a response.

The ordering of these patches seems a little weird.  Could you group
them so that it's libmesode, then profanity, then libstrophe?

Regards,
Leo
Raghav Gururajan Feb. 23, 2021, 5:32 p.m. UTC | #2
Hi Leo!

> There is just one failing test here.  If there's really no way around
> it, disable that one, but try to investigate the link error first.

I already tried disabling that test. Two other tests that comes next to 
it fail in same way.

> Since this issue is related, we should really get to the roots of it.
> Let's hope for a response.

Yeah.

> The ordering of these patches seems a little weird.  Could you group
> them so that it's libmesode, then profanity, then libstrophe?

Sure.

Regards,
RG.
Leo Prikler Feb. 23, 2021, 5:39 p.m. UTC | #3
Am Dienstag, den 23.02.2021, 12:32 -0500 schrieb Raghav Gururajan:
> Hi Leo!
> 
> > There is just one failing test here.  If there's really no way
> > around
> > it, disable that one, but try to investigate the link error first.
> 
> I already tried disabling that test. Two other tests that comes next
> to 
> it fail in same way.
In other words all tests fail to build?  That would indicate some
serious breakage.

Regards,
Leo
Raghav Gururajan Feb. 23, 2021, 5:41 p.m. UTC | #4
Hi Leo!

> In other words all tests fail to build?  That would indicate some
> serious breakage.

That would be 3 tests.

Regards,
RG.
diff mbox series

Patch

From bd09f7f9f90a912cc130d6a1f882210f90d51b4d Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Tue, 23 Feb 2021 12:03:23 -0500
Subject: [PATCH 6/6] gnu: libstrophe: Disable static libraries.

* gnu/packages/messaging.scm (libstrope) [arguments]<#:tests?>: New argument.
<#:configure-flags>[--disable-static]: New flag.
---
 gnu/packages/messaging.scm | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f9173113bf..4bd5534fa6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2050,6 +2050,11 @@  manual SSL certificate verification.")
        (sha256
         (base32 "11d341avsfr0z4lq15cy5dkmff6qpy91wkgzdpfdy31l27pa1g79"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f         ; https://github.com/strophe/libstrophe/issues/175
+       #:configure-flags
+       (list
+        "--disable-static")))
     (inputs
      `(("expat" ,expat)
        ("openssl" ,openssl)))
-- 
2.30.1