diff mbox series

[bug#74248,2/3] gnu: Add xorgproto-next.

Message ID 13c254e76ee10c819fba0cd2aa9979648a0f9317.1731011374.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series Update xorg-server and xwayland for CVE-2024-9632. | expand

Commit Message

Kaelyn Takata Nov. 7, 2024, 9:41 p.m. UTC
* gnu/packages/xorg.scm (xorgproto-next): New variable.

Change-Id: Ib546f911c717611a1dbe10ef6f02e47e00e88a51
---
 gnu/packages/xorg.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 1c5201a836..97a2d8a78a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -264,6 +264,28 @@  (define-public xorgproto
 the core protocol and (many) extensions for the X Window System.")
     (license license:x11)))
 
+(define-public xorgproto-next
+  (package
+    (name "xorgproto")
+    (version "2024.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://xorg/individual/proto"
+                                  "/xorgproto-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0nfbbi4j130m2gxzp20hp642xizbbl68jpbzahiq8nw183yja8ip"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+     ;; To get util-macros in (almost?) all package inputs.
+     (list util-macros))
+    (home-page "https://cgit.freedesktop.org/xorg/proto/xorgproto")
+    (synopsis "Xorg protocol headers")
+    (description
+     "This package provides the headers and specification documents defining
+the core protocol and (many) extensions for the X Window System.")
+    (license license:x11)))
+
 (define-public bigreqsproto
   (package
     (name "bigreqsproto")