diff mbox series

[bug#43348] Profanity

Message ID 13b0be17-7d6d-dc37-c5d7-44171301f477@disroot.org
State Accepted
Headers show
Series [bug#43348] Profanity | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan Sept. 13, 2020, 4:38 a.m. UTC
Hi Danny!

> please, for existing packages, try to be as clear as possible in the commit
> messages in what is changed (only one related set of things should be changed
> per commit).
> 
> In this case the commit confounds things:
> 
> * Changing the build-system reference.  This does not enable runtime
> features--which is what the commit message's topic stated that the commit does.
> * Changing the autoconf method.  This does not enable runtime features--which
> is what the commit message's topic stated that the commit does.
> * Adding Python as a NATIVE input.  What is that about?  Is profanity using
> a Python program as a compiler only?
> * I think that moving those native-inputs to inputs, while correct, does not
> enable runtime features--which is what the commit message's topic stated that
> the commit does.
> * Please use two spaces (after the period) in order to separate sentences.
> * Moving blocks around makes review much harder for users.
> 
> The goal of those commit messages, and of the commit rules, is to make it
> easy for each user to see at a glance what topic each commit changes.

You are correct. I always do these in a hurry, sorry about that. Please
find the attached patches.

Regards,
RG.

Comments

Danny Milosavljevic Sept. 13, 2020, 9:11 a.m. UTC | #1
Hi RG,

thank you!  That's almost perfect.

I still don't get it why python-wrapper is a *native* input in order to support
Python plugins.  That would mean the Python plugins are only used at build time
and not used at runtime.  Is that correct?
Raghav Gururajan Sept. 13, 2020, 9:12 a.m. UTC | #2
Hi Danny!

> thank you!  That's almost perfect.

\o/ :-)

> I still don't get it why python-wrapper is a *native* input in order to support
> Python plugins.  That would mean the Python plugins are only used at build time
> and not used at runtime.  Is that correct?

As far as I understand, the package uses the python binary to compile a
component, which will be used to add/remove python plugins.

Regards,
RG.
Danny Milosavljevic Sept. 13, 2020, 9:54 a.m. UTC | #3
Hi RG,

On Sun, 13 Sep 2020 05:12:04 -0400
Raghav Gururajan <raghavgururajan@disroot.org> wrote:

> > I still don't get it why python-wrapper is a *native* input in order to support
> > Python plugins.  That would mean the Python plugins are only used at build time
> > and not used at runtime.  Is that correct?  
> 
> As far as I understand, the package uses the python binary to compile a
> component, which will be used to add/remove python plugins.

I doubt it.

$ ./pre-inst-env guix gc --references `./pre-inst-env guix build profanity`
[...]
/gnu/store/09a5iq080g9b641jyl363dr5jkkvnhcn-python-3.8.2

So it keeps a runtime reference to python.  I suspect it just embeds a Python
interpreter.  So it should probably be a regular input.
The question is whether the plugins written in Python actually work or not.
Usually they require some extra PYTHONPATH or whatever setting in order to
find stuff.  Just raw Python is often not enough.

But we'll see.

Moved python-wrapper to regular input.

Pushed patchset to master.

I edited the commit messages not to include internal rationale like that that
change is the correct change (for glib-or-gtk-build-system) or whatever.

If we need that it should go in the source code as a comment--where it can
be easily seen.
diff mbox series

Patch

From 1c777d5bd598f97bf6978f863d6752e0942ab236 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 13 Sep 2020 00:30:10 -0400
Subject: [PATCH 4/4] gnu: profanity: Change build system.

* gnu/package/messaging.scm (profanity) [build-system]: Change from
gnu to glib-or-gtk.

Glib-or-gtk is the appropriate build system, as the package depends
on glib and gtk+.
---
 gnu/packages/messaging.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 232d80a5fc..ef553e2acb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1783,7 +1783,7 @@  are both supported).")
        (sha256
         (base32
          "00j9l9v62rz9hprgiy1vrz8v3v59ph18h8kskqxr31fgqvjv5xr3"))))
-    (build-system gnu-build-system)
+    (build-system glib-or-gtk-build-system)
     (arguments
      `(#:configure-flags
        (list
-- 
2.28.0