[bug#73287,v4,1/3] gnu: Add embree-2.
Commit Message
* gnu/packages/graphics.scm: (embree-2): New variable.
Change-Id: I2b2143b4d93c402ba940d408280ef1b37ab552ea
---
gnu/packages/graphics.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
base-commit: bc630c5ebed27edd821ec363706f8b9cf1ee05cc
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Ivan Vilata-i-Balaguer <ivan@selidor.net>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -491,6 +492,30 @@ (define-public embree-3
(base32
"1kcvz7g6j56anv9zjyd3gidxl46vipw0gg82lns12m45cd43iwxm"))))))
+(define-public embree-2
+ (package/inherit embree
+ (version "2.17.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/RenderKit/embree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name (package-name embree) version))
+ (sha256
+ (base32 "19v60zdfix33c772x6dzmhsarhafsns8qy7c2ysqr7a9j16whgql"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments embree)
+ ((#:configure-flags configure-flags)
+ #~(append (list "-DEMBREE_MAX_ISA=NONE" "-DEMBREE_TUTORIALS=OFF")
+ #$configure-flags))))
+ (inputs (modify-inputs (package-inputs embree)
+ (replace "tbb" tbb-2020)))
+ ;; Embree requires SSE2 support, so build only for x86-based architectures.
+ (supported-systems (list "i686-linux" "x86_64-linux"))
+ (description (string-append (package-description embree) "
+
+Please note that this version requires a processor with SSE2 support."))))
+
(define-public openvdb
(package
(name "openvdb")