[bug#77564,2/2] gnu: gimp@3: Wrap GI_TYPELIB_PATH and GUIX_PYTHONPATH.

Message ID 133ac337a3a2853a9c530cdd4c668598566e9e6e.1743891590.git.liliana.prikler@gmail.com
State New
Headers
Series Make GIMP 3 the new GIMP |

Commit Message

Liliana Marie Prikler April 5, 2025, 10:18 p.m. UTC
  Without this, Python-Fu scripts will fail to import gi and GObject-related
packages.

* gnu/packages/gimp.scm (gimp-3)[#:phases]: Add ‘wrap’.
---
 gnu/packages/gimp.scm | 14 +++++++++++++-
 1 file changed, 13 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index ef03992f2d..07f005bb18 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -454,7 +454,19 @@  (define-public gimp-3
                  (lambda _
                    (mkdir-p (string-append #$output:doc "/share"))
                    (rename-file (string-append #$output "/share/doc")
-                                (string-append #$output:doc "/share/doc")))))))
+                                (string-append #$output:doc "/share/doc"))))
+               (add-after 'install 'wrap
+                 (lambda* _
+                   (for-each
+                    (lambda (prog)
+                      (wrap-program prog
+                        `("GI_TYPELIB_PATH" suffix
+                          (,(getenv "GI_TYPELIB_PATH")))
+                        `("GUIX_PYTHONPATH" suffix
+                          (,(getenv "GUIX_PYTHONPATH")))))
+                    (find-files (string-append #$output "/bin")
+                                (lambda (_ stat)
+                                  (eq? 'regular (stat:type stat))))))))))
     (inputs (modify-inputs (package-inputs gimp-2)
               (replace "gtk+" gtk+)
               (prepend libxmu libxt)