[bug#74464] gnu: buildah: Update to 1.38.0.

Message ID 131cdfdc62eaf4f259811b2bd0ec3090a395da76.1732198091.git.~@wolfsden.cz
State New
Headers
Series [bug#74464] gnu: buildah: Update to 1.38.0. |

Commit Message

Tomas Volf Nov. 21, 2024, 2:08 p.m. UTC
  * gnu/packages/containers.scm (buildah): Update to 1.38.0.
<native-inputs>: Use go-1.22.

Change-Id: I4a36345f91fde84fdbf5b4ef4cd5dc2749c90327
---
 gnu/packages/containers.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
  

Comments

Aaron Covrig Nov. 23, 2024, 9:24 p.m. UTC | #1
user guix
usertag 74464 + reviewed-looks-good
thanks

Guix QA review form submission:
The package builds for me and doesn&apos;t show any signs of breaking
changes when building a couple simple Dockerfiles

Items marked as checked: Lint warnings, Package builds, Commit messages
  
Zheng Junjie Nov. 24, 2024, 1:12 a.m. UTC | #2
Tomas Volf <~@wolfsden.cz> writes:

> * gnu/packages/containers.scm (buildah): Update to 1.38.0.
> <native-inputs>: Use go-1.22.

[native-inputs]: Use go-1.22.

>
> Change-Id: I4a36345f91fde84fdbf5b4ef4cd5dc2749c90327
> ---
>  gnu/packages/containers.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
> index adae2f5bfc..c883592be6 100644
> --- a/gnu/packages/containers.scm
> +++ b/gnu/packages/containers.scm
> @@ -606,7 +606,7 @@ (define-public podman-compose
>  (define-public buildah
>    (package
>      (name "buildah")
> -    (version "1.37.5")
> +    (version "1.38.0")
>      (source
>       (origin
>         (method git-fetch)
> @@ -614,7 +614,7 @@ (define-public buildah
>               (url "https://github.com/containers/buildah")
>               (commit (string-append "v" version))))
>         (sha256
> -        (base32 "0m15pizivwwq2cnmsyhsz5h8zblcvpy06lj82vypg358spq3y0l4"))
> +        (base32 "1lnl5v8d5p4g0rm4d90rw4hdh066w7v8r9g1h0v1z533mbgxgry8"))
>         (file-name (git-file-name name version))))
>      (build-system gnu-build-system)
>      (arguments
> @@ -684,7 +684,7 @@ (define-public buildah
>                    lvm2))
>      (native-inputs
>       (list bats
> -           go-1.21
> +           go-1.22
>             go-github-com-go-md2man
>             pkg-config))
>      (synopsis "Build @acronym{OCI, Open Container Initiative} images")
pushed, closing.
  
Tomas Volf Nov. 24, 2024, 2:55 p.m. UTC | #3
Hi,

thank you for merging my patches.  I just have a question regarding the
following:

Z572 <zhengjunjie@iscas.ac.cn> writes:

> Tomas Volf <~@wolfsden.cz> writes:
>
>> * gnu/packages/containers.scm (buildah): Update to 1.38.0.
>> <native-inputs>: Use go-1.22.
>
> [native-inputs]: Use go-1.22.

I tried following the `(standards)Indicating the Part Changed' manual,
since Guix claims to follow the Change log format but I did not manage
to find its own documentation for it.  According to the info manual, the
`[..]'  should be used for conditional changes (which this is not).  The
`<..>' should be used to indicate part changed (which this is).

Could you please point me to a documentation where I could read more on
what Guix's deviations from the GNU Change Logs format are so that I can
adhere to it next time?

Thank you and have a nice day,
Tomas
  
Zheng Junjie Nov. 24, 2024, 4:03 p.m. UTC | #4
Tomas Volf <~@wolfsden.cz> writes:

> Hi,
>
> thank you for merging my patches.  I just have a question regarding the
> following:
>
> Z572 <zhengjunjie@iscas.ac.cn> writes:
>
>> Tomas Volf <~@wolfsden.cz> writes:
>>
>>> * gnu/packages/containers.scm (buildah): Update to 1.38.0.
>>> <native-inputs>: Use go-1.22.
>>
>> [native-inputs]: Use go-1.22.
>
> I tried following the `(standards)Indicating the Part Changed' manual,
> since Guix claims to follow the Change log format but I did not manage
> to find its own documentation for it.  According to the info manual, the
> `[..]'  should be used for conditional changes (which this is not).  The
> `<..>' should be used to indicate part changed (which this is).

see

https://mail.gnu.org/archive/html/guix-devel/2019-06/msg00092.html

and

https://mail.gnu.org/archive/html/guix-devel/2023-09/msg00124.html

>
> Could you please point me to a documentation where I could read more on
> what Guix's deviations from the GNU Change Logs format are so that I can
> adhere to it next time?

And Unfortunately there doesn't seem to be such a thing, I remember a
previous discussion at guix-devel about summarizing a document, but
there was no follow-up.

>
> Thank you and have a nice day,
> Tomas
  

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index adae2f5bfc..c883592be6 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -606,7 +606,7 @@  (define-public podman-compose
 (define-public buildah
   (package
     (name "buildah")
-    (version "1.37.5")
+    (version "1.38.0")
     (source
      (origin
        (method git-fetch)
@@ -614,7 +614,7 @@  (define-public buildah
              (url "https://github.com/containers/buildah")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "0m15pizivwwq2cnmsyhsz5h8zblcvpy06lj82vypg358spq3y0l4"))
+        (base32 "1lnl5v8d5p4g0rm4d90rw4hdh066w7v8r9g1h0v1z533mbgxgry8"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
@@ -684,7 +684,7 @@  (define-public buildah
                   lvm2))
     (native-inputs
      (list bats
-           go-1.21
+           go-1.22
            go-github-com-go-md2man
            pkg-config))
     (synopsis "Build @acronym{OCI, Open Container Initiative} images")