diff mbox series

[bug#72582,2/2] Revert "gnu: chez-scheme-for-racket: Fix building on riscv64-linux."

Message ID 12acca683476e8f29df324a7652aad5befab6619.1723406971.git.philip@philipmcgrath.com
State New
Headers show
Series gnu: racket: Update to 8.14. | expand

Commit Message

Philip McGrath Aug. 11, 2024, 9:38 p.m. UTC
Native code generation for riscv64-linux is supported:
this commit masked a bug somewhere in our packaging or the build
modes we're using.

This reverts commit 0c96f7932de50c81f4b4714f287520699107c8bb.
---
 gnu/packages/chez.scm | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index aa081f1677..0874a9a817 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -130,9 +130,8 @@  (define* (target-chez-arch #:optional (system
     #f)
    ((target-ppc32? system)
     "ppc32")
-   ;; This is apparently not ready in chez-scheme-for-racket.
-   ;((target-riscv64? system)
-   ; "rv64")
+   ((target-riscv64? system)
+    "rv64")
    ((string-prefix? "loongarch64-" system)
     "la64")
    (else