diff mbox series

[bug#68202,3/5] gnu: openssl: Fix building on x86_64-linux-gnux32.

Message ID 1252b9d0117ae10a018a304a54ab1fad9ef27326.1704179455.git.efraim@flashner.co.il
State New
Headers show
Series Add support for x86_64-linux-gnux32 | expand

Commit Message

Efraim Flashner Jan. 2, 2024, 7:27 a.m. UTC
* gnu/packages/tls.scm (target->openssl-target): Add entry for
x86_64-linux-gnux32.

Change-Id: Icbbdb76134da0811b8493c55ca2d3acdb77c5883
---
 gnu/packages/tls.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 75e6370c72..208a7ff640 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -5,7 +5,7 @@ 
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2019, 2021-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2021-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -429,6 +429,8 @@  (define (target->openssl-target target)
              (cond
               ((target-x86-32? target)
                "x86")
+              ((target-x32? target)
+               "x32")
               ((target-x86-64? target)
                "x86_64")
               ((target-mips64el? target)