[bug#77371,02/12] gnu: Add python-resample.
Commit Message
* gnu/packages/statistics.scm (python-resample): New variable.
Change-Id: I0bd8ed6c0532c5dba6efd9d15b056da401072fcf
---
gnu/packages/statistics.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
@@ -2813,6 +2813,39 @@ (define-public python-openturns
functionalities needed to treat uncertainties in studies.")
(license license:lgpl3+)))
+(define-public python-resample
+ (package
+ (name "python-resample")
+ (version "1.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "resample" version))
+ (sha256
+ (base32 "08hbnkfplhyh1pc9ls20pldxslhsp3azb8ibgc4wjg5q801pid2b"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy python-scipy))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/scikit-hep/resample")
+ (synopsis "Resampling-based inference in Python")
+ (description "This package provides a resampling-based inference based on
+data resampling and permutation.
+
+Features:
+
+@itemize
+@item Bootstrap resampling: ordinary or balanced with optional stratification
+@item Extended bootstrap resampling: also varies sample size
+@item Parametric resampling: Gaussian, Poisson, gamma, etc.)
+@item Jackknife estimates of bias and variance of any estimator
+@item Compute bootstrap confidence intervals (percentile or BCa) for any
+estimator
+@item Permutation-based variants of traditional statistical tests (USP test of
+independence and others)
+@item Tools for working with empirical distributions (CDF, quantile, etc.)
+@end itemize")
+ (license license:bsd-3)))
+
(define-public r-coda
(package
(name "r-coda")