diff mbox series

[bug#74290,v3,13/51] gnu: bash: Avoid hang when cross-built for the Hurd.

Message ID 123d8bbbda215439ea79e7b94c6b3e7b425ffcbe.1731999203.git.janneke@gnu.org
State New
Headers show
Series Add support for x86_64-gnu, aka the 64bit Hurd. | expand

Commit Message

Janneke Nieuwenhuizen Nov. 19, 2024, 6:54 a.m. UTC
For example, without this patch bash hangs while configuring diffutils.
Reproducer:

cat >x.awk <<EOF
x... repeat 16384 (the actual pipe size) times
EOF

* gnu/packages/bash.scm (bash): When cross-building for the Hurd, add new
"create-pipesize.h" stage.

Change-Id: I02c1dcf2d63849626ba3448cd52766db822dc77c
---
 gnu/packages/bash.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 56918d79bd..642a405985 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -175,6 +175,20 @@  (define-public bash
 
         #:phases
         (modify-phases %standard-phases
+          ,@(if (and (target-hurd?) (not (system-hurd?)))
+                `((add-after 'configure 'create-pipesize.h
+                    ;; The Bash Makefile mentions how PIPESIZE calculation is
+                    ;; "technically wrong" when cross-compiling, and offers no
+                    ;; way to override it.  On the 64bit Hurd, it can make
+                    ;; bash hang.
+                    (lambda _
+                      (with-directory-excursion "builtins"
+                        (with-output-to-file "psize.aux"
+                          (lambda _ (display "dummy to pacify make\n")))
+                        (with-output-to-file "pipesize.h"
+                          (lambda _ (display "#define PIPESIZE 16384\n")))))))
+                '())
+
           (add-after 'install 'install-sh-symlink
             (lambda* (#:key outputs #:allow-other-keys)
               ;; Add a `sh' -> `bash' link.