diff mbox series

[bug#53704] Bump

Message ID 11a5c7052c3f76dcf41fc614fed551ee019c1f96.camel@telenet.be
State New
Headers show
Series [bug#53704] Bump | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M Feb. 12, 2022, 1:31 p.m. UTC
Hi,

I've modified the package definition and patch a bit to
make it simpler (visualboyadvance-m-fix-rpath.patch now only removed
things), cross-compilable (it uses cc-for-target instead of hardcoding
"gcc" and LIBRARY_PATH is unused) and avoid using constructs that
are being deprecated (%build-inputs --> this-package-input).

The list+local-file will have to be replaced by search-patches.

Cross-compilation is untested because gtk+ cannot currently be
cross-compiled.

It seems to work, at least the application starts, I don't have any VBA
games to test it with.

Greetings,
Maxime.

Comments

Charles Feb. 12, 2022, 11:45 p.m. UTC | #1
Thanks for the review, Maxime! That is a lot of stuff I did not know about. Your new version of the patch works for me except for the (list (local-file part which I think should be (search-patches.

What should I do about the library code duplication and licensing issues? Should I bring it upu with the project maintainers?

------- Original Message -------

On Saturday, February 12th, 2022 at 7:31 AM, Maxime Devos <maximedevos@telenet.be> wrote:

> Hi,
>
> I've modified the package definition and patch a bit to
>
> make it simpler (visualboyadvance-m-fix-rpath.patch now only removed
>
> things), cross-compilable (it uses cc-for-target instead of hardcoding
>
> "gcc" and LIBRARY_PATH is unused) and avoid using constructs that
>
> are being deprecated (%build-inputs --> this-package-input).
>
> The list+local-file will have to be replaced by search-patches.
>
> Cross-compilation is untested because gtk+ cannot currently be
>
> cross-compiled.
>
> It seems to work, at least the application starts, I don't have any VBA
>
> games to test it with.
>
> Greetings,
>
> Maxime.
Charles Feb. 27, 2022, 12:19 a.m. UTC | #2
What are the next steps for this project? Do the licensing issues make it not allowed to be in guix?

------- Original Message -------

On Saturday, February 12th, 2022 at 5:45 PM, Charles <charles.b.jackson@protonmail.com> wrote:

> Thanks for the review, Maxime! That is a lot of stuff I did not know about. Your new version of the patch works for me except for the (list (local-file part which I think should be (search-patches.
>
> What should I do about the library code duplication and licensing issues? Should I bring it upu with the project maintainers?
>
> ------- Original Message -------
>
> On Saturday, February 12th, 2022 at 7:31 AM, Maxime Devos maximedevos@telenet.be wrote:
>
> > Hi,
> >
> > I've modified the package definition and patch a bit to
> >
> > make it simpler (visualboyadvance-m-fix-rpath.patch now only removed
> >
> > things), cross-compilable (it uses cc-for-target instead of hardcoding
> >
> > "gcc" and LIBRARY_PATH is unused) and avoid using constructs that
> >
> > are being deprecated (%build-inputs --> this-package-input).
> >
> > The list+local-file will have to be replaced by search-patches.
> >
> > Cross-compilation is untested because gtk+ cannot currently be
> >
> > cross-compiled.
> >
> > It seems to work, at least the application starts, I don't have any VBA
> >
> > games to test it with.
> >
> > Greetings,
> >
> > Maxime.
M Feb. 27, 2022, 10:52 a.m. UTC | #3
Charles schreef op za 12-02-2022 om 23:45 [+0000]:
> What should I do about the library code duplication and licensing issues?
> Should I bring it upu with the project maintainers?

The licensing should be brought up with the project maintainers.
The unbundling can be brought up with the maintainers, while probably
they will keep bundling, perhaps they could support some
"-DUSE_SYSTEM_ZLIB" kind of configure flags.

If upstream is unresponsive or keeps bundling, it may be possible to
unbundle it in Guix itself even though upstream bundles.

Greetings,
Maxime
diff mbox series

Patch

From 6ec4f4224aa360d5c233941148465ad1c8c77f33 Mon Sep 17 00:00:00 2001
From: Charles Jackson <charles.b.jackson@protonmail.com>
Date: Mon, 31 Jan 2022 23:24:17 -0600
Subject: [PATCH] Fix rpath

---
 CMakeLists.txt | 4 ----
 1 file changed, 0 insertions(+), 4 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 010c9b0e..3a959b59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -610,9 +610,5 @@  if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID STREQUAL Clang)
 
         set(MY_C_LINKER_FLAGS ${MY_C_LINKER_FLAGS} -Wl,-allow-multiple-definition)
 
-        if(CMAKE_PREFIX_PATH)
-            list(GET CMAKE_PREFIX_PATH 0 prefix_path_first)
-            set(MY_C_LINKER_FLAGS ${MY_C_LINKER_FLAGS} "-Wl,-rpath-link=${prefix_path_first}/lib")
-        endif()
     endif()
 
     # set linker flags