diff mbox series

[bug#67403,6/8] gnu: intelmetool: Update to new style.

Message ID 1171674c705f1f6500e8961dc4baba25268ffef3.1700752093.git.GNUtoo@cyberdimension.org
State New
Headers show
Series Coreboot related patches. | expand

Commit Message

Denis 'GNUtoo' Carikli Nov. 23, 2023, 3:27 p.m. UTC
* gnu/packages/flashing-tools.scm (intelmetool): Update to new style.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Change-Id: I2c1996cdb2d41804bad55acef25375062edc11de
---
 gnu/packages/flashing-tools.scm | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 8959ed66ab..c93e4616ea 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -473,18 +473,18 @@  (define-public intelmetool
     (inputs
      (list pciutils zlib))
     (arguments
-     `(#:make-flags
-       (list "CC=gcc"
-             "INSTALL=install"
-             (string-append "PREFIX=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-        (add-after 'unpack 'chdir
-          (lambda _
-            (chdir "util/intelmetool")
-            #t))
-        (delete 'configure)
-        (delete 'check))))
+     (list
+      #:make-flags
+      #~(list "CC=gcc"
+              "INSTALL=install"
+              (string-append "PREFIX=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir
+            (lambda _
+              (chdir "util/intelmetool")))
+          (delete 'configure)
+          (delete 'check))))
     (home-page "https://github.com/zamaudio/intelmetool")
     (synopsis "Intel Management Engine tools")
     (description "This package provides tools for working with Intel