diff mbox series

[bug#68709] gnu: emacs-citar: Fix autoloads and restore tests

Message ID 10f970b791c6281a24e643714c0415fcab656246.1706135680.git.bienjensu@gmail.com
State New
Headers show
Series [bug#68709] gnu: emacs-citar: Fix autoloads and restore tests | expand

Commit Message

Edward Wilson Jan. 24, 2024, 10:34 p.m. UTC
The default build-system emacs doesn't properly expand cl-lib macros when
compiling autoloads. This patch changes the `#:emacs` build argument, fixing a
present bug (reproducible by requiring citar-autoloads in a minimal
environment). This change also allows the validation of compiled autoloads to
succeed, hence the test phase is restored.

* gnu/packages/emacs-xyz.scm (emacs-citar): Change build-system emacs and
restore tests

Change-Id: Id56de922e5220383f8c5015a01e39b4aa2ea8cfb
---
 gnu/packages/emacs-xyz.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)


base-commit: ffc5fefce370f5fc01091869e13fdf525be1e0c0

Comments

Andrew Tropin Jan. 26, 2024, 4:49 p.m. UTC | #1
On 2024-01-24 22:34, Edward Wilson wrote:

> The default build-system emacs doesn't properly expand cl-lib macros when
> compiling autoloads. This patch changes the `#:emacs` build argument, fixing a
> present bug (reproducible by requiring citar-autoloads in a minimal
> environment). This change also allows the validation of compiled autoloads to
> succeed, hence the test phase is restored.
>
> * gnu/packages/emacs-xyz.scm (emacs-citar): Change build-system emacs and
> restore tests
>
> Change-Id: Id56de922e5220383f8c5015a01e39b4aa2ea8cfb
> ---
>  gnu/packages/emacs-xyz.scm | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index ad8c72e97d..b8c97d1767 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -23633,6 +23633,7 @@ (define-public emacs-citar
>      (build-system emacs-build-system)
>      (arguments
>       (list
> +      #:emacs emacs-no-x
>        #:tests? #true
>        #:test-command #~(list "emacs" "--batch" "-L" "."
>                               "-l" "test/citar-test.el"
> @@ -23642,10 +23643,7 @@ (define-public emacs-citar
>        #:phases #~(modify-phases %standard-phases
>                     (add-before 'build 'set-home
>                       (lambda _
> -                       (setenv "HOME" "/tmp")))
> -                   ;; XXX: The following phase reports bogus errors. Suppress
> -                   ;; it for now.
> -                   (delete 'validate-compiled-autoloads))))
> +                       (setenv "HOME" "/tmp"))))))
>      (propagated-inputs (list emacs-auctex
>                               emacs-citeproc-el
>                               emacs-embark
>
> base-commit: ffc5fefce370f5fc01091869e13fdf525be1e0c0

Hi Edward!

Thank you very much for the fix, added a trailing dot to commit message
and pushed as
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=8ae8b9804f
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ad8c72e97d..b8c97d1767 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23633,6 +23633,7 @@  (define-public emacs-citar
     (build-system emacs-build-system)
     (arguments
      (list
+      #:emacs emacs-no-x
       #:tests? #true
       #:test-command #~(list "emacs" "--batch" "-L" "."
                              "-l" "test/citar-test.el"
@@ -23642,10 +23643,7 @@  (define-public emacs-citar
       #:phases #~(modify-phases %standard-phases
                    (add-before 'build 'set-home
                      (lambda _
-                       (setenv "HOME" "/tmp")))
-                   ;; XXX: The following phase reports bogus errors. Suppress
-                   ;; it for now.
-                   (delete 'validate-compiled-autoloads))))
+                       (setenv "HOME" "/tmp"))))))
     (propagated-inputs (list emacs-auctex
                              emacs-citeproc-el
                              emacs-embark