[bug#77756] gnu: utf8proc: add version 2.10.0

Message ID 1091cab37da3d18a45312a54d7b1ef0373a45952.1744406580.git.luispereira.tkd@gmail.com
State New
Headers
Series [bug#77756] gnu: utf8proc: add version 2.10.0 |

Commit Message

Luis Pereira April 11, 2025, 9:23 p.m. UTC
  I have successfully build neovim@0.11.0 and want to submit the pat ches
that make it available for everyone.

As this is my first contribution, I'm submitting this update first, as
it is required to accomplish that build, hopping for feedback on
improving my contributions to follow guidelines.

I opted to create a new version of the package, like the previous
approach for 2.7.0, to avoid depency conflicts. Is this the preferable
approach?

Thanks

* gnu/packages/textutils.scm (utf8proc): Add version 2.10.0

Change-Id: I56646a37f7029bba4974b85e5cb593f798d0bfe0
---
 gnu/packages/textutils.scm | 50 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)


base-commit: f7c41ab31f5023023385500f6eb9083d23dd1ccb
  

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index c886b009be..428366b890 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -76,6 +76,7 @@  (define-module (gnu packages textutils)
   #:use-module (gnu packages golang-crypto)
   #:use-module (gnu packages golang-xyz)
   #:use-module (gnu packages java)
+  #:use-module (gnu packages julia)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
@@ -269,6 +270,55 @@  (define-public utf8proc-2.7.0
           ;; For tests
           ("ruby" ,ruby-2.7)))))))
 
+(define-public utf8proc-2.10.0
+  (package
+    (inherit utf8proc-2.7.0)
+    (name "utf8proc")
+    (version "2.10.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaStrings/utf8proc")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1n1k67x39sk8xnza4w1xkbgbvgb1g7w2a7j2qrqzqaw1lyilqsy2"))))
+    (native-inputs (let ((UNICODE_VERSION "16.0.0"))
+                     `(,(origin
+                          (method url-fetch)
+                          (uri (string-append
+                                "https://www.unicode.org/Public/"
+                                UNICODE_VERSION
+                                "/ucd/DerivedCoreProperties.txt"))
+                          (sha256 (base32
+                                   "1gfsq4vdmzi803i2s8ih7mm4fgs907kvkg88kvv9fi4my9hm3lrr"))) ,(origin
+                                                                                                
+                                                                                                (method
+                                                                                                 url-fetch)
+                                                                                                
+                                                                                                (uri
+                                                                                                 (string-append
+                                                                                                  "https://www.unicode.org/Public/"
+                                                                                                  UNICODE_VERSION
+                                                                                                  "/ucd/NormalizationTest.txt"))
+                                                                                                
+                                                                                                (sha256
+                                                                                                 (base32
+                                                                                                  "1cffwlxgn6sawxb627xqaw3shnnfxq0v7cbgsld5w1z7aca9f4fq")))
+                       ,(origin
+                          (method url-fetch)
+                          (uri (string-append
+                                "https://www.unicode.org/Public/"
+                                UNICODE_VERSION
+                                "/ucd/auxiliary/GraphemeBreakTest.txt"))
+                          (sha256 (base32
+                                   "1d9w6vdfxakjpp38qjvhgvbl2qx0zv5655ph54dhdb3hs9a96azf")))
+                       ;; For tests
+                       ,perl
+                       ,ruby
+                       ,julia)))))
+
 (define-public libconfuse
   (package
     (name "libconfuse")