diff mbox series

[bug#68301] gnu: Add guile-yamlpp.

Message ID 10761021-237d-8f0f-b140-654ca149236c@gmail.com
State New
Headers show
Series [bug#68301] gnu: Add guile-yamlpp. | expand

Commit Message

Georgios Athanasiou Jan. 7, 2024, 11:27 a.m. UTC
* gnu/packages/guile-xyz.scm (guile-yamlpp): New variable.

Change-Id: I54694eeea17e414df4d7778a2e119f3f995c20e4
---
  gnu/packages/guile-xyz.scm | 27 +++++++++++++++++++++++++++
  1 file changed, 27 insertions(+)

Comments

Mathieu Othacehe Jan. 7, 2024, 6:34 p.m. UTC | #1
> * gnu/packages/guile-xyz.scm (guile-yamlpp): New variable.

Applied, thanks!

For bonus points, you could see why yaml-cpp doesn't cross-compile and
check after that whether guile-yamlpp is cross-compiling as well :)

Mathieu
Georgios Athanasiou Jan. 8, 2024, 10:42 p.m. UTC | #2
Hi Mathieu,

That was fast, thanks.  Latest yaml-cpp release version 0.8.0 seems to

solve the cross-compilation issue (as well as bringing other

benefits).  Maybe I'll submit a patch for the upgrade (I do worry a

bit about negatively affecting any of the ~25 dependent packages,

though backwards compatibility seems excellent).

Best wishes,

G.
Zheng Junjie Jan. 9, 2024, 3:16 p.m. UTC | #3
Georgios Athanasiou <o8cu77@otenet.gr> writes:

> Hi Mathieu,
>
> That was fast, thanks.  Latest yaml-cpp release version 0.8.0 seems to
>
> solve the cross-compilation issue (as well as bringing other
>
> benefits).  Maybe I'll submit a patch for the upgrade (I do worry a
>
> bit about negatively affecting any of the ~25 dependent packages,
>
> though backwards compatibility seems excellent).
>
> Best wishes,
>
> G.

see https://issues.guix.gnu.org/67066, looks like this patch didn't push
to master?
Mathieu Othacehe Jan. 10, 2024, 2:27 p.m. UTC | #4
Hello,

> see https://issues.guix.gnu.org/67066, looks like this patch didn't push
> to master?

Strange, re-applied.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 75e3754046..9ef4ef0573 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -5428,6 +5428,33 @@  (define-public guile-libyaml
  ffi-helper from nyacc.")
        (license license:lgpl3+))))

+(define-public guile-yamlpp
+  (package
+    (name "guile-yamlpp")
+    (version "0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/yorgath/guile-yamlpp")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "14mlqi7hw7pi9scwk1g432issnqcn185pd8na2plijxq55cy0iq7"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool pkg-config))
+    (inputs (list guile-3.0 yaml-cpp))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "GUILE_EXTENSIONS_PATH")
+            (files (list "lib/guile/3.0")))))
+    (home-page "https://gitlab.com/yorgath/guile-yamlpp")
+    (synopsis "Guile YAML reader/writer based on @code{yaml-cpp}")
+    (description
+     "A module for GNU Guile to read and write YAML files.  It works using
+bindings to the @code{yaml-cpp} C++ library.")
+    (license license:gpl3+)))
+
  (define-public schmutz
    (let ((commit "add24588c59552537b8f1316df99a0cdd62c221e")
          (revision "1"))