diff mbox series

[bug#66822] gnu: Add pantheon-photos

Message ID 1037e695d17deb0a6766493dfe1e0697ce1efdc8.1698596120.git.altadil@protonmail.com
State New
Headers show
Series [bug#66822] gnu: Add pantheon-photos | expand

Commit Message

altadil Oct. 29, 2023, 4:16 p.m. UTC
* gnu/packages/pantheon.scm (pantheon-photos): New variable.

Change-Id: I08a10db8a03cd6ddde936b892d917e8b7d421124
---
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux.
 gnu/packages/pantheon.scm | 59 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)


base-commit: 26565f1bc8548011bc0e1b821a9a957db1bc2d8f
prerequisite-patch-id: b3506da85d629b0f39af22c99c099838a4720442

Comments

Christopher Baines Oct. 30, 2023, 1:16 p.m. UTC | #1
altadil via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/pantheon.scm (pantheon-photos): New variable.
>
> Change-Id: I08a10db8a03cd6ddde936b892d917e8b7d421124
> ---
> guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
> for the following --system= options:
> - x86_64-linux
> - i686-linux
> - aarch64-linux.
>  gnu/packages/pantheon.scm | 59 +++++++++++++++++++++++++++++++++++++++
>  1 file changed, 59 insertions(+)

There are problems applying this patch to master.

> +
>  (define-public pantheon-stylesheet
>    (package
>      (name "pantheon-stylesheet")
>
> base-commit: 26565f1bc8548011bc0e1b821a9a957db1bc2d8f
> prerequisite-patch-id: b3506da85d629b0f39af22c99c099838a4720442

I can't see the package definition for pantheon-stylesheet, do you have
another patch to add that?
altadil Oct. 30, 2023, 1:50 p.m. UTC | #2
------- Original Message -------
On Monday, October 30th, 2023 at 13:16, Christopher Baines <mail@cbaines.net> wrote:

> altadil via Guix-patches via guix-patches@gnu.org writes:
> 
> > * gnu/packages/pantheon.scm (pantheon-photos): New variable.
> > 
> > Change-Id: I08a10db8a03cd6ddde936b892d917e8b7d421124
> > ---
> > guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
> > for the following --system= options:
> > - x86_64-linux
> > - i686-linux
> > - aarch64-linux.
> > gnu/packages/pantheon.scm | 59 +++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 59 insertions(+)
> 
> 
> There are problems applying this patch to master.
> 
> > +
> > (define-public pantheon-stylesheet
> > (package
> > (name "pantheon-stylesheet")
> > 
> > base-commit: 26565f1bc8548011bc0e1b821a9a957db1bc2d8f
> > prerequisite-patch-id: b3506da85d629b0f39af22c99c099838a4720442
> 
> 
> I can't see the package definition for pantheon-stylesheet, do you have
> another patch to add that?

Yes, that patch is https://issues.guix.gnu.org/66821
I guess I am using git wrong, because they should be independent, but I’m unsure how to do this properly. :/
Christopher Baines Oct. 30, 2023, 2:15 p.m. UTC | #3
Altadil <Altadil@protonmail.com> writes:

> ------- Original Message -------
> On Monday, October 30th, 2023 at 13:16, Christopher Baines <mail@cbaines.net> wrote:
>
>> altadil via Guix-patches via guix-patches@gnu.org writes:
>> 
>> > +
>> > (define-public pantheon-stylesheet
>> > (package
>> > (name "pantheon-stylesheet")
>> > 
>> > base-commit: 26565f1bc8548011bc0e1b821a9a957db1bc2d8f
>> > prerequisite-patch-id: b3506da85d629b0f39af22c99c099838a4720442
>> 
>> 
>> I can't see the package definition for pantheon-stylesheet, do you have
>> another patch to add that?
>
> Yes, that patch is https://issues.guix.gnu.org/66821
> I guess I am using git wrong, because they should be independent, but I’m unsure how to do this properly. :/

Having a series with multiple patches is fine, but Git needs to generate
the patches as part of a series, and ideally you send all the patches in
the series to the same bug number.

There some information here about using git format-patch for a series of
patches, you can also ask for help on IRC if you're still unsure:

  https://guix.gnu.org/en/manual/devel/en/html_node/Sending-a-Patch-Series.html#Multiple-Patches-1

Could you try sending all of these patches together as a series to
66821@debbugs.gnu.org ? If that works, then the other issues can be
closed.

Thanks,

Chris
altadil Nov. 5, 2023, 3:09 p.m. UTC | #4
Closing as the patch has been sent as part of a series (https://issues.guix.gnu.org/66821).
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 55cb65045e..3465e5cb37 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -25,14 +25,18 @@  (define-module (gnu packages pantheon)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages image)
   #:use-module (gnu packages package-management)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages photo)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages webkit)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages)
   #:use-module (guix build-system meson)
@@ -132,6 +136,61 @@  (define-public pantheon-calculator
 desktop.")
     (license license:gpl3)))
 
+(define-public pantheon-photos
+  (package
+    (name "pantheon-photos")
+    (version "2.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/elementary/photos")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1aw77sdh2z7fah3vbi68145wc0xqg2afch1kswvgkmij0f0n04jn"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'disable-schema-cache-generation
+                    (lambda _
+                      (setenv "DESTDIR" "/")))
+                  (add-after 'install 'install-symlinks
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (bin (string-append out
+                                                 "/bin/io.elementary.photos"))
+                             (link (string-append out "/bin/pantheon-photos")))
+                        (symlink bin link)))))))
+    (native-inputs (list desktop-file-utils
+                         `(,glib "bin") intltool pkg-config vala))
+    (inputs (list geocode-glib-with-libsoup2
+                  gexiv2
+                  granite-6
+                  gstreamer
+                  gst-plugins-base
+                  gtk+
+                  json-glib
+                  libexif
+                  libgee
+                  libgphoto2
+                  libgudev
+                  libhandy
+                  libraw
+                  libsoup-minimal-2
+                  libwebp
+                  rest
+                  sqlite
+                  webkitgtk-with-libsoup2))
+    (synopsis "Photo viewer and organizer designed for the Pantheon desktop")
+    (description
+     "Photos is an image viewer and organizer.  It originally comes
+from elementary OS and is designed for the Pantheon desktop environment (but can
+also be used on others.")
+    (home-page "https://elementary.io/open-source")
+    (license license:lgpl2.1+)))
+
 (define-public pantheon-stylesheet
   (package
     (name "pantheon-stylesheet")