diff mbox series

[bug#65528,1/2] gnu: Add r-oompadata.

Message ID 101858d305defcbe2f111fc2b93bd02c6d982499.1692961567.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#65528,1/2] gnu: Add r-oompadata. | expand

Commit Message

nafkhamdc Aug. 25, 2023, 11:06 a.m. UTC
* gnu/packages/cran.scm (r-oompadata): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 5c8e8dff607da710ce13a506e2dc42e98ee96737

Comments

Ricardo Wurmus Aug. 28, 2023, 8:27 a.m. UTC | #1
Applied, thank you for the patch!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 223d1d3a3d..65e472860c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2281,6 +2281,29 @@  (define-public r-oenb
 @url{https://www.oenb.at/en/Statistics/User-Defined-Tables/webservice.html}.")
     (license license:gpl2+)))
 
+(define-public r-oompadata
+  (package
+    (name "r-oompadata")
+    (version "3.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "oompaData" version))
+              (sha256
+               (base32
+                "0gdp7bghgpz3q0h06w8r926x7wkpcvkpyf0v5qfi1qixbpvk5fdf"))))
+    (properties `((upstream-name . "oompaData")))
+    (build-system r-build-system)
+    (home-page "http://oompa.r-forge.r-project.org/")
+    (synopsis "Data to illustrate OOMPA algorithms")
+    (description
+     "OOMPA offers R packages for gene expression and proteomics analysis.
+OOMPA uses S4 classes to construct object-oriented tools with a consistent
+user interface.  All higher level analysis tools in OOMPA are compatible
+with the eSet classes defined in BioConductor.  The lower level processing
+tools offer an alternative to parts of BioConductor, but can also be used
+to enhance existing BioConductor packages.")
+    (license license:asl2.0)))
+
 (define-public r-orgmassspecr
   (package
     (name "r-orgmassspecr")