diff mbox series

[bug#72703,v2] gnu: gtk+-2: Disable UI tests on aarch64.

Message ID 101515ca7bd0194a35b642044322529f3eb3ddbd.1724111051.git.jonathan@terracrypt.net
State New
Headers show
Series [bug#72703,v2] gnu: gtk+-2: Disable UI tests on aarch64. | expand

Commit Message

Jonathan Frederickson Aug. 19, 2024, 11:44 p.m. UTC
* gnu/packages/gtk.scm (gtk+-2): Disable ui-tests on aarch64. They seem to be
flaky on aarch64, and I haven't been able to get the package to build without
this change.

Change-Id: I5aa5a89a2874ad1c737cba16c3aaeedced606de3
---
 gnu/packages/gtk.scm | 6 ++++++
 1 file changed, 6 insertions(+)


base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8

Comments

Jonathan Frederickson Aug. 19, 2024, 11:53 p.m. UTC | #1
Alright, I think I got it, though I'll admit to being a bit unfamiliar with g-expressions. My primary laptop is aarch64, but I have an x86_64 server set up for build offloads. I ran a 'guix build --system=x86_64-linux' on the commits before and after and it didn't seem to trigger a rebuild, which is good.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 04183fa806..667e0d4dbf 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -980,6 +980,12 @@  (define-public gtk+-2
                 (("g_test_add_func \\(\"/recent-manager.*;") ""))
               (substitute* "gtk/tests/defaultvalue.c"
                 (("return g_test_run\\(\\);") ""))
+              ;; UI tests seem to be flaky on aarch64
+              #$@(if (string=? (%current-system) "aarch64-linux")
+                     (list
+                      #~(substitute* "gtk/tests/testing.c"
+                          (("g_test_add_func \\(\"/ui-tests.*;") "")))
+                     #~())
               ;; These require XPM support in Gdk-Pixbuf which is obsolete.
               (substitute* "gtk/tests/textbuffer.c"
                 (("g_test_add_func.*test_fill_empty\\);")