[bug#77203,2/4] gnu: Add go-github-com-wadey-gocovmerge.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-wadey-gocovmerge): New
variable.
Change-Id: Idde447ff494064fbc74c973b49ff0fd5699f9346
---
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -57,6 +57,7 @@
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
+;;; Copyright © 2025 45mg <45mg.writes@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -15430,6 +15431,31 @@ (define-public go-github-com-warpfork-go-fsx
;; BSD-3-Clause terms.
(license (list license:expat license:asl2.0 license:bsd-3))))
+(define-public go-github-com-wadey-gocovmerge
+ (package
+ (name "go-github-com-wadey-gocovmerge")
+ (version "0.0.0-20160331181800-b5bfa59ec0ad")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wadey/gocovmerge")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00m7kxcmmw0l9z0m7z6ii06n5j4bcrxqjbhxjbfzmsdgdsvkic31"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/wadey/gocovmerge"))
+ (propagated-inputs (list go-golang-org-x-tools))
+ (home-page "https://github.com/wadey/gocovmerge")
+ (synopsis "Merge coverprofile results from multiple go cover runs")
+ (description
+ "gocovmerge takes the results from multiple @command{go test -coverprofile} runs and
+merges them into one profile.")
+ (license license:bsd-2)))
+
(define-public go-github-com-whyrusleeping-base32
(package
(name "go-github-com-whyrusleeping-base32")