diff mbox series

[bug#64502] gnu: Add emacs-weyland-yutani-theme.

Message ID 0f8f8a4c05b78c167821db47b704e0864688f0ee.1688676665.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64502] gnu: Add emacs-weyland-yutani-theme. | expand

Commit Message

Ahmad Draidi July 6, 2023, 8:51 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-weyland-yutani-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 961ffca1c75141cbb351d143b22b673638e9659d

Comments

Nicolas Goaziou July 6, 2023, 10:14 p.m. UTC | #1
Hello,

Ahmad Draidi via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-weyland-yutani-theme): New
> variable.

Thank you. Some comments follow.

> +(define-public emacs-weyland-yutani-theme
> +  (let ((commit "e89a63a62e071180c9cdd9067679fadc3f7bf796")
> +        (revision "0"))
> +    (package
> +      (name "emacs-weyland-yutani-theme")
> +      (version (git-version "20210802.2251" revision commit))

Base version is actually "0.1", not "20210802.2251", per "Version"
keyword in main file.

> +      (description
> +       "Weyland Yutani is a dark Emacs theme based on the Alien movie franchise")

The final full stop is missing.

> +      (license license:gpl3))))

License is actually gpl3+.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 21aa820f0b..e6bd3ba5d4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35614,6 +35614,28 @@  (define-public emacs-nord-theme
 syntax highlighting and UI components.")
     (license license:expat)))
 
+(define-public emacs-weyland-yutani-theme
+  (let ((commit "e89a63a62e071180c9cdd9067679fadc3f7bf796")
+        (revision "0"))
+    (package
+      (name "emacs-weyland-yutani-theme")
+      (version (git-version "20210802.2251" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jstaursky/weyland-yutani-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0gxlz9b7fvbjkqxsyb4l75g7jsxyms0i1vpnb6y499hl115akcaz"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/jstaursky/weyland-yutani-theme")
+      (synopsis "Emacs theme based on the Alien movie franchise")
+      (description
+       "Weyland Yutani is a dark Emacs theme based on the Alien movie franchise")
+      (license license:gpl3))))
+
 (define-public emacs-janet-mode
   (let ((commit "2f5bcabcb6953e1ed1926ba6a2328c453e8b4ac7"))
     (package