diff mbox series

[bug#71788] gnu: hwloc: Update to 2.11.1.

Message ID 0f8acd5a9ae5e8df7e141f2c17e5fedd35264eb5.1720780359.git.ludo@gnu.org
State New
Headers show
Series [bug#71788] gnu: hwloc: Update to 2.11.1. | expand

Commit Message

Ludovic Courtès July 12, 2024, 10:33 a.m. UTC
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/mpi.scm (hwloc-2): Update to 2.11.1.
[native-inputs]: Add BASH.

Co-authored-by: Philippe SWARTVAGHER <phil.swart@gmx.fr>
Change-Id: If5531cb82911833153b0e795e9f20b0d0ae940c2
---
 gnu/packages/mpi.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)


base-commit: 2d6a3799fcda5c017f653c6e96b91964b07a7ee0

Comments

Ludovic Courtès July 18, 2024, 3:41 p.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> skribis:

> From: Ludovic Courtès <ludovic.courtes@inria.fr>
>
> * gnu/packages/mpi.scm (hwloc-2): Update to 2.11.1.
> [native-inputs]: Add BASH.
>
> Co-authored-by: Philippe SWARTVAGHER <phil.swart@gmx.fr>
> Change-Id: If5531cb82911833153b0e795e9f20b0d0ae940c2

After some additional testing, and with qa.guix being overwhelmed these
days, I went ahead and pushed it as
fcd3c5d3aa2894218f357d69f7a307ebc3b318bc.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 6270108b16..4c18da30ef 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -35,6 +35,7 @@  (define-module (gnu packages mpi)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages fabric-management)
   #:use-module (gnu packages gcc)
@@ -143,7 +144,7 @@  (define-public hwloc-1
 (define-public hwloc-2
   (package
     (inherit hwloc-1)
-    (version "2.10.0")
+    (version "2.11.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -151,11 +152,12 @@  (define-public hwloc-2
                                   "/hwloc-" version ".tar.bz2"))
               (sha256
                (base32
-                "14hkmq2hrs4j5f0sf32aazgbhgbdvj7lwapy35jvwbyyr5hds183"))))
+                "1ikhg35pll9zs628n2nii3ranz9j850hykqqcrgy2p12mpzzpk84"))))
 
-    ;; libnuma is no longer needed.
+    (native-inputs (modify-inputs (package-native-inputs hwloc-1)
+                     (append bash)))              ;for completion tests
     (inputs (modify-inputs (package-inputs hwloc-1)
-              (delete "numactl")))
+              (delete "numactl")))               ;libnuma is no longer needed.
     (arguments
      (substitute-keyword-arguments (package-arguments hwloc-1)
        ((#:phases phases)