[bug#76513,rust-team,17/77] gnu: Add rust-ttf-parser-0.24.

Message ID 0f729121fd7b3460d37f0ffa5685ffc8ed78fadb.1740340805.git.wongandj@icloud.com
State New
Headers
Series Add module (gnu packages typst) and packages |

Commit Message

Andrew Wong Feb. 23, 2025, 8:21 p.m. UTC
  * gnu/packages/crates-graphics.scm (rust-ttf-parser-0.24): New variable.

Change-Id: I309f247e06f7eba96374f1d26f5e87f573397763
---
 gnu/packages/crates-graphics.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 568c693a9f..611de8e0e5 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -4683,6 +4683,29 @@  (define-public rust-svgtypes-0.15
     (description "This package provides SVG types parser.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-ttf-parser-0.24
+  (package
+    (name "rust-ttf-parser")
+    (version "0.24.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ttf-parser" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0jmcif537g3smzgcx0vfr4wwq4pnaypa7dnklasfhf2xzy813qjv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-core-maths" ,rust-core-maths-0.1))))
+    (home-page "https://github.com/harfbuzz/ttf-parser")
+    (synopsis
+     "high-level, safe, zero-allocation font parser for TrueType, OpenType, and AAT.")
+    (description
+     "This package provides a high-level, safe, zero-allocation font parser for
+@code{TrueType}, @code{OpenType}, and AAT.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-tiff-0.9
   (package
     (name "rust-tiff")