diff mbox series

[bug#47006,1/2] gnu: lld: Update to 12.0.0.

Message ID 0f6c5b692df8d06a0d7adddc9e5abf93894a366f.1631195387.git.liliana.prikler@gmail.com
State Accepted
Headers show
Series [bug#47006,1/2] gnu: lld: Update to 12.0.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Sept. 9, 2021, 1:32 p.m. UTC
* gnu/packages/llvm.scm (llvm-subprojects-origin, %llvm-project-12.0.0-hash):
New variables.
(lld-11, lld-12): New variables.
(lld): Point to lld-11.
---
 gnu/packages/llvm.scm | 44 ++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 43 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 4394194939..220116cbfb 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -92,6 +92,22 @@  as \"x86_64-linux\"."
   (string-append "https://github.com/llvm/llvm-project/releases/download"
                  "/llvmorg-" version "/" component "-" version ".src.tar.xz"))
 
+(define* (llvm-subprojects-origin components version base32-hash
+                                  #:optional (patches '()))
+  (origin
+    (method url-fetch)
+    (uri (llvm-uri "llvm-project" version))
+    (sha256 base32-hash)
+    (patches (map search-patch patches))
+    (modules '((guix build utils)
+               (ice-9 ftw)))
+    (snippet
+     `(for-each
+       (lambda (file)
+         (unless (member file '("." ".." ,@components))
+           (delete-file-recursively file)))
+       (scandir ".")))))
+
 (define* (clang-runtime-from-llvm llvm hash
                                   #:optional (patches '()))
   (package
@@ -882,7 +898,7 @@  of programming tools as well as libraries with equivalent functionality.")
 (define-public clang clang-9)
 (define-public clang-toolchain clang-toolchain-9)
 
-(define-public lld
+(define-public lld-11
   (package
     (name "lld")
     (version "11.0.0")
@@ -906,6 +922,32 @@  of programming tools as well as libraries with equivalent functionality.")
 components which highly leverage existing libraries in the larger LLVM Project.")
     (license license:asl2.0))) ; With LLVM exception
 
+(define %llvm-project-12.0.0-hash
+  (base32 "0a1n88dmbwp1ww7h3ykf0s001cndk1bm3i2cj1y2sh548f4nilcy"))
+
+(define-public lld-12
+  (package
+    (inherit lld-11)
+    (version "12.0.0")
+    (source (llvm-subprojects-origin '("lld" "libunwind") version
+                                     %llvm-project-12.0.0-hash))
+    (arguments
+     `(,@(package-arguments lld-11)
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'dissect
+           (lambda _
+             ;; Find libunwind in unpacked sources
+             (substitute* "lld/MachO/CMakeLists.txt"
+               (("\\$\\{LLVM_MAIN_SRC_DIR\\}/\\.\\./libunwind")
+                (string-append (getcwd) "/libunwind")))
+             ;; chdir to actual source folder
+             (chdir "lld"))))))
+    (inputs
+     `(("llvm" ,llvm-12)))))
+
+(define-public lld lld-11)
+
 (define-public lldb
   (package
     (name "lldb")