diff mbox series

[bug#71984,v2,1/2] gnu: python-pygments: Update to 2.15.1.

Message ID 0f57c0f06155f605c76e24e2ef8655f7a8a9d738.1720464215.git.felgru@posteo.net
State New
Headers show
Series [bug#71984,v2,1/2] gnu: python-pygments: Update to 2.15.1. | expand

Commit Message

Felix Gruber July 8, 2024, 6:43 p.m. UTC
From: Ricardo Wurmus <rekado@elephly.net>

* gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests.
[native-inputs]: Add python-pytest.
---
 gnu/packages/python-xyz.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

Comments

Ricardo Wurmus July 18, 2024, 2:56 p.m. UTC | #1
Felix Gruber <felgru@posteo.net> writes:

> From: Ricardo Wurmus <rekado@elephly.net>
>
> * gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
> [build-system]: Use pyproject-build-system.
> [arguments]: Run tests.
> [native-inputs]: Add python-pytest.

I don't understand why this should go to he master branch.  It's already
on the python-team branch and it hasn't been merged, because there has
been quite a bit of fallout from this change and the changes it
prompted.

I'd prefer to just bring the python-team branch in order and merge it
once core-updates is ready.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c432e9b65..05d4a8b710 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7019,18 +7019,23 @@  (define-public python-doc8
 (define-public python-pygments
   (package
     (name "python-pygments")
-    (version "2.12.0")
+    (version "2.15.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Pygments" version))
        (sha256
         (base32
-         "1sr6iqh21xi6p8aba4wa9pqfhjbbpcvn9jcsx0ggy4lniw8idcay"))))
-    (build-system python-build-system)
+         "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+    (build-system pyproject-build-system)
     (arguments
-     ;; FIXME: Tests require sphinx, which depends on this.
-     '(#:tests? #f))
+     (list
+      #:test-flags
+      ;; Some tests require sphinx, which depends on this, so we only run
+      ;; basic tests.
+      '(list "--ignore-glob=tests/*/*")))
+    (native-inputs
+     (list python-pytest))
     (home-page "https://pygments.org/")
     (synopsis "Syntax highlighting")
     (description