diff mbox series

[bug#57050,v4,09/14] gnu: chez-scheme: Make bootfiles regular inputs.

Message ID 0f44a1c29bd332808927cc4bf679fd11dc88cf98.1661626113.git.philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: Update Racket to 8.6. Add Zuo. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath Aug. 27, 2022, 6:55 p.m. UTC
* gnu/packages/chez.scm (chez-scheme)[native-inputs]: Move
'chez-scheme-bootstrap-bootfiles' to ...
[inputs]: ... this field.
[arguments]<#:phases>: Update 'unpack-bootfiles' accordingly.
(chez-scheme-for-racket)[native-inputs]: Move
'chez-scheme-for-racket-bootstrap-bootfiles' to ...
[inputs]: ... this field.
---
 gnu/packages/chez.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index b59398578a..c87786c091 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -293,6 +293,7 @@  (define-public chez-scheme
     (build-system gnu-build-system)
     (inputs
      (list
+      chez-scheme-bootstrap-bootfiles
       `(,util-linux "lib") ;<-- libuuid
       zlib
       lz4
@@ -300,8 +301,7 @@  (define-public chez-scheme
       ;; for X11 clipboard support in expeditor:
       ;; https://github.com/cisco/ChezScheme/issues/9#issuecomment-222057232
       libx11))
-    (native-inputs (list chez-scheme-bootstrap-bootfiles
-                         chez-nanopass-bootstrap
+    (native-inputs (list chez-nanopass-bootstrap
                          stex-bootstrap))
     (native-search-paths
      (list (search-path-specification
@@ -338,7 +338,7 @@  (define-public chez-scheme
               (when (directory-exists? "boot")
                 (delete-file-recursively "boot"))
               (copy-recursively
-               (search-input-directory (or native-inputs inputs)
+               (search-input-directory inputs
                                        "lib/chez-scheme-bootfiles")
                "boot")))
           ;; NOTE: The custom Chez 'configure' script doesn't allow
@@ -449,12 +449,12 @@  (define-public chez-scheme-for-racket
     (source #f) ; avoid problematic cycle with racket.scm
     (inputs
      (modify-inputs (package-inputs chez-scheme)
-       (delete "libx11" "util-linux:lib")))
+       (delete "libx11" "util-linux:lib")
+        (replace "chez-scheme-bootstrap-bootfiles"
+          chez-scheme-for-racket-bootstrap-bootfiles)))
     (native-inputs
      (modify-inputs (package-native-inputs chez-scheme)
-       (prepend zuo)
-       (replace "chez-scheme-bootstrap-bootfiles"
-         chez-scheme-for-racket-bootstrap-bootfiles)))
+       (prepend zuo)))
     (arguments
      (substitute-keyword-arguments (package-arguments chez-scheme)
        ((#:out-of-source? _ #f)