[bug#77590,v2,2/3] gnu: Add hdf5-examples.

Message ID 0f14a3f2820462522e3bf967e1c25d4b34578de8.1744035216.git.david.elsing@posteo.net
State New
Headers
Series None |

Commit Message

David Elsing April 7, 2025, 2:24 p.m. UTC
  * gnu/packages/maths.scm (hdf5-examples): New variable.
---
 gnu/packages/maths.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d11fff3bc5..6d7466774d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2016,6 +2016,20 @@  (define-public hdf5
     (license (license:x11-style
               "https://support.hdfgroup.org/ftp/HDF5/releases/COPYING.html"))))
 
+;; This package builds and tests the examples, but has empty output.
+(define-public hdf5-examples
+  (package/inherit hdf5
+    (name "hdf5-examples")
+    (arguments
+     (substitute-keyword-arguments (package-arguments hdf5)
+       ((#:phases _ #f)
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'chdir
+              (lambda _
+                (chdir "HDF5Examples")))))))
+    (inputs (list hdf5 zlib))
+    (native-inputs (list autoconf-2.71 automake gfortran))))
+
 ;; Keep this in sync with the current hdf5 package.
 (define-public hdf-java
   (package