[bug#75391,10/12] gnu: Add rust-optfield-0.3.
Commit Message
* gnu/packages/crates-io.scm (rust-optfield-0.3): New variable.
Change-Id: I5686f2d92365833459959312f8da6a312d558d85
---
gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
@@ -49230,6 +49230,29 @@ (define-public rust-opml-1
(description "This package provides an OPML parser for Rust.")
(license (list license:expat license:asl2.0))))
+(define-public rust-optfield-0.3
+ (package
+ (name "rust-optfield")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "optfield" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "079a5n7lhqsj444fkgk580vra5v2nhym7czwnky9iip9rljz0ngs"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/roignpar/optfield")
+ (synopsis "macro that generates structs with optional fields")
+ (description
+ "This package provides a macro that generates structs with optional fields.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-optick-1
(package
(name "rust-optick")