diff mbox series

[bug#68716,gnome-team,v4,7/7] gnu: Deprecate gnome meta-package.

Message ID 0ef52d621063bf7cd5487b287b4d4421ec3b786c.1708087345.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#68716,gnome-team,v4,1/7] gnu: Split gnome into more meta-packages. | expand

Commit Message

Liliana Marie Prikler Jan. 25, 2024, 3:55 p.m. UTC
GNOME is not a "one size fits all" environment, but with the introduction of
World, Circle, and to some extent Developer Extras and recent explorations of
mobile form factors much more customizable towards the needs of users.  As
such, it is silly to insist on a single meta-package to make everyone happy.

* gnu/packages/gnome.scm (gnome): Deprecate.
---
 gnu/packages/gnome.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Vivien Kraus Feb. 16, 2024, 5:44 p.m. UTC | #1
Hello!

The whole series seems good to me. I reconfigured my system and
rebooted into it, and it works.

Best regards,

Vivien

Le jeudi 25 janvier 2024 à 16:55 +0100, Liliana Marie Prikler a écrit :
> GNOME is not a "one size fits all" environment, but with the
> introduction of
> World, Circle, and to some extent Developer Extras and recent
> explorations of
> mobile form factors much more customizable towards the needs of
> users.  As
> such, it is silly to insist on a single meta-package to make everyone
> happy.
> 
> * gnu/packages/gnome.scm (gnome): Deprecate.
> ---
>  gnu/packages/gnome.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index f3d1548fe9..e47a4576f5 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -237,6 +237,7 @@ (define-module (gnu packages gnome)
>    #:use-module (guix build-system meson)
>    #:use-module (guix build-system python)
>    #:use-module (guix build-system trivial)
> +  #:use-module (guix deprecation)
>    #:use-module (guix download)
>    #:use-module (guix git-download)
>    #:use-module ((guix licenses) #:prefix license:)
> @@ -10280,7 +10281,7 @@ (define-public gnome-essential-extras
>  a good GNOME experience, mixed from core dependencies and other
> implicitly
>  relied-on packages.")))
>  
> -(define-public gnome
> +(define-deprecated/public gnome #f
>    (package
>      (inherit (gnome-meta-package "gnome"
>                                   (append-map package-propagated-
> inputs
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f3d1548fe9..e47a4576f5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -237,6 +237,7 @@  (define-module (gnu packages gnome)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
+  #:use-module (guix deprecation)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -10280,7 +10281,7 @@  (define-public gnome-essential-extras
 a good GNOME experience, mixed from core dependencies and other implicitly
 relied-on packages.")))
 
-(define-public gnome
+(define-deprecated/public gnome #f
   (package
     (inherit (gnome-meta-package "gnome"
                                  (append-map package-propagated-inputs