diff mbox series

[bug#62252,v3,09/19] gnu: python-hatchling: Use upstream homepage.

Message ID 0eeef48b6f5e136faac5aaf8c3ba997fa8caba0c.camel@gmail.com
State New
Headers show
Series None | expand

Commit Message

Liliana Marie Prikler March 26, 2023, 6:19 a.m. UTC
* gnu/packages/python-xyz.scm (python-hatchling)[home-page]: Use
“hatch.pypa.io”.
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ricardo Wurmus March 26, 2023, 7:55 a.m. UTC | #1
Hi,

I have built python-orjson on wip-rekado-rust-team, which is based on
top of the rust-team (but rebased on top of current master).  This lets
us build python-fastapi without having to remove orjson.

(I worked on packaging python-fastapi for python-pytorch-lightning.)

My python-fastapi package looks like this:

--8<---------------cut here---------------start------------->8---
+(define-public python-fastapi
+  (package
+    (name "python-fastapi")
+    (version "0.95.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "fastapi" version))
+              (sha256
+               (base32
+                "062fy794mv0yfb4ac5yaaqh6a0k7npa0n7dc4x0a5ncx1sqzvm4r"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags '(list "tests")))
+    (propagated-inputs (list python-pydantic python-starlette))
+    (native-inputs (list python-anyio
+                         python-black
+                         python-coverage
+                         python-databases
+                         python-email-validator
+                         python-flask
+                         python-hatchling
+                         python-httpx
+                         python-isort
+                         python-jose
+                         python-multipart
+                         python-mypy
+                         python-orjson
+                         python-passlib
+                         python-peewee
+                         python-pre-commit
+                         python-pytest
+                         python-pyyaml
+                         python-sqlalchemy
+                         python-types-orjson
+                         python-types-ujson
+                         python-ujson
+                         python-uvicorn))
…
--8<---------------cut here---------------end--------------->8---

The update of pathspec looks good to me, though with 300+ rebuilds this
whole thing should probably be built out on a feature branch first.

The starlette update also looks good to me, though you could move it to
0.26.1 (with hash 1gd9pvcfifrlaskqz741n4rbsgljn6jnjgkscvj211paay87knj1).
I used the version form pypi which didn’t come with tests, so I don’t
know if running the tests of 0.26.1 is more difficult than running those
of 0.25.

In any case, this whole patch set looks good to me.  I’m sorry for
stepping on your toes with python-hatchling.
Liliana Marie Prikler March 26, 2023, 8:23 a.m. UTC | #2
Am Sonntag, dem 26.03.2023 um 09:55 +0200 schrieb Ricardo Wurmus:
> Hi,
> 
> I have built python-orjson on wip-rekado-rust-team, which is based on
> top of the rust-team (but rebased on top of current master).  This
> lets us build python-fastapi without having to remove orjson.
Do we have an ETA on wip-rekado-rust-team?  And most importantly, does
it come with antioxidant? :)

> (I worked on packaging python-fastapi for python-pytorch-lightning.)
> 
> My python-fastapi package looks like this:
> 
> --8<---------------cut here---------------start------------->8---
> +(define-public python-fastapi
> +  (package
> +    (name "python-fastapi")
> +    (version "0.95.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "fastapi" version))
> +              (sha256
> +               (base32
> +               
> "062fy794mv0yfb4ac5yaaqh6a0k7npa0n7dc4x0a5ncx1sqzvm4r"))))
> +    (build-system pyproject-build-system)
> +    (arguments
> +     (list
> +      #:test-flags '(list "tests")))
> +    (propagated-inputs (list python-pydantic python-starlette))
> +    (native-inputs (list python-anyio
> +                         python-black
> +                         python-coverage
> +                         python-databases
> +                         python-email-validator
> +                         python-flask
> +                         python-hatchling
> +                         python-httpx
> +                         python-isort
> +                         python-jose
> +                         python-multipart
> +                         python-mypy
> +                         python-orjson
> +                         python-passlib
> +                         python-peewee
> +                         python-pre-commit
> +                         python-pytest
> +                         python-pyyaml
> +                         python-sqlalchemy
> +                         python-types-orjson
> +                         python-types-ujson
> +                         python-ujson
> +                         python-uvicorn))
> …
> --8<---------------cut here---------------end--------------->8---
> 
> The update of pathspec looks good to me, though with 300+ rebuilds
> this whole thing should probably be built out on a feature branch
> first.
Hmm, 380 rebuilds would be fine if it was just python imho, but since
it appears to cut into R and Gnome as well, I get your point.  Should
we do the typical -next dance?

> The starlette update also looks good to me, though you could move it
> to 0.26.1 (with hash
> 1gd9pvcfifrlaskqz741n4rbsgljn6jnjgkscvj211paay87knj1).
> I used the version form pypi which didn’t come with tests, so I don’t
> know if running the tests of 0.26.1 is more difficult than running
> those of 0.25.
I actually haven't tested 0.26.1 – the patch was lying around for some
while before committing, since I didn't have the other parts running
back then.  I'll probably send a v4 once I check whether there's an
issue and what that issue might be.

Cheers
Ricardo Wurmus March 26, 2023, 10:14 a.m. UTC | #3
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 26.03.2023 um 09:55 +0200 schrieb Ricardo Wurmus:
>> Hi,
>> 
>> I have built python-orjson on wip-rekado-rust-team, which is based on
>> top of the rust-team (but rebased on top of current master).  This
>> lets us build python-fastapi without having to remove orjson.
> Do we have an ETA on wip-rekado-rust-team?  And most importantly, does
> it come with antioxidant? :)

wip-rekado-rust-team is held up by the merge of the rust-team branch;
that one can only be merged once we’ve built rust on aarch64.  This
hasn’t succeeded yet as the builds time out or fail due to lack of
resources.  I’m trying to build it manually on ci.guix.gnu.org (i.e. not
through cuirass), so I have more control over options.

When rust-team has been merged, we’d build the few extra commits added
by wip-rekado-rust-team and merged that too.

> Hmm, 380 rebuilds would be fine if it was just python imho, but since
> it appears to cut into R and Gnome as well, I get your point.  Should
> we do the typical -next dance?

I don’t know.  I thought: rebase a feature branch on top of master,
start building it on ci, merge as soon as it’s done.

>> The starlette update also looks good to me, though you could move it
>> to 0.26.1 (with hash
>> 1gd9pvcfifrlaskqz741n4rbsgljn6jnjgkscvj211paay87knj1).
>> I used the version form pypi which didn’t come with tests, so I don’t
>> know if running the tests of 0.26.1 is more difficult than running
>> those of 0.25.
> I actually haven't tested 0.26.1 – the patch was lying around for some
> while before committing, since I didn't have the other parts running
> back then.  I'll probably send a v4 once I check whether there's an
> issue and what that issue might be.

Good good!
Liliana Marie Prikler April 2, 2023, 10:49 a.m. UTC | #4
Am Sonntag, dem 26.03.2023 um 12:14 +0200 schrieb Ricardo Wurmus:
> > Hmm, 380 rebuilds would be fine if it was just python imho, but
> > since it appears to cut into R and Gnome as well, I get your point.
> > Should we do the typical -next dance?
> 
> I don’t know.  I thought: rebase a feature branch on top of master,
> start building it on ci, merge as soon as it’s done.
I split the series into one part that can go to master and the rest
went to the new "clinguin" branch.  How do I get that to build on CI?

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 81101be1da..659339d2a5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1795,7 +1795,7 @@  (define-public python-hatchling
            python-pathspec
            python-pluggy
            python-tomli))
-    (home-page "https://pypi.org/project/hatchling/")
+    (home-page "https://hatch.pypa.io/")
     (synopsis "Extensible Python build backend")
     (description "Hatchling is an extensible Python build backend.")
     (license license:expat)))