diff mbox series

[bug#49859] gnu: Remove dillo.

Message ID 0ee91a928acdf41a8f3fb932827dfb45423ad0d1.1628039334.git.leo@famulari.name
State Accepted
Headers show
Series [bug#49859] gnu: Remove dillo. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Aug. 4, 2021, 1:08 a.m. UTC
As discussed in <https://bugs.gnu.org/46602>, Dillo does not include a
supported implementation of TLS / HTTPS, and there does not seem to be
any activity upstream to improve that.

* gnu/packages/web-browsers.scm (dillo): Remove variable.
---
 gnu/packages/web-browsers.scm | 31 -------------------------------
 1 file changed, 31 deletions(-)

Comments

Leo Famulari Aug. 4, 2021, 1:29 a.m. UTC | #1
My plan is to push these patches within 2 weeks.
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index bd5ed1b5ac..6e011e8b14 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -147,37 +147,6 @@  management, extensions such as advertisement blocker and colorful tabs.")
     (home-page "https://www.midori-browser.org")
     (license license:lgpl2.1+)))
 
-(define-public dillo
-  (package
-    (name "dillo")
-    (version "3.0.5")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://www.dillo.org/download/"
-                                  "dillo-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
-    (build-system gnu-build-system)
-    (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (inputs `(("fltk" ,fltk)
-              ("fontconfig" ,fontconfig)
-              ("libjpeg" ,libjpeg-turbo)
-              ("libpng" ,libpng)
-              ("libxcursor" ,libxcursor)
-              ("libxft" ,libxft)
-              ("libxi" ,libxi)
-              ("libxinerama" ,libxinerama)
-              ("openssl" ,openssl-1.0) ;XXX try latest openssl for dillo > 3.0.5
-              ("perl" ,perl)
-              ("zlib" ,zlib)))
-    (synopsis "Very small and fast graphical web browser")
-    (description "Dillo is a minimalistic web browser particularly intended for
-older or slower computers and embedded systems.")
-    (home-page "https://www.dillo.org")
-    (license license:gpl3+)))
-
 (define-public links
   (package
     (name "links")