From 7e29f26288bf2a6764f0b90cd7eb36c2b48e5e7e Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Thu, 24 Mar 2022 17:12:30 +0200
Subject: [PATCH] gnu: games: Add robotfindskitten.
* gnu/packages/games.scm (robotfindskitten): New variable.
---
gnu/packages/games.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)
@@ -69,6 +69,7 @@
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,58 @@ (define-public retux
license:gpl2+
license:gpl3+)))))
+(define-public robotfindskitten
+ ;; Despite what guix lint says, version 2.8284271.702 is newer than
+ ;; 1600003_201b. See ChangeLog for version history.
+ (package
+ (name "robotfindskitten")
+ (version "2.8284271.702")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/"
+ name
+ "/"
+ name
+ "/releases/download/"
+ version
+ "/"
+ name
+ "-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1bwrkxm83r9ajpkd6x03nqvmdfpf5vz6yfy0c97pq3v3ykj74082"))
+ ;; When built with guix, all characters are displayed in the background
+ ;; colour pair for some reason. If it is not set by the program, this
+ ;; is not happening, so the game is coloured properly.
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "src/robotfindskitten.c"
+ (("\\(void\\) bkgd \\( \\(chtype\\) COLOR_PAIR\\(WHITE\\) \\);")
+ ""))))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-silent-rules")
+ #:make-flags ;install to /bin instead of /game
+ (list (string-append "execgamesdir="
+ (assoc-ref %outputs "out") "/bin"))))
+ (inputs (list ncurses))
+ (outputs '("out" "debug"))
+ ;; The following are the original synopsis and description by the authors.
+ (synopsis "Zen Simulation of robot finding kitten")
+ (description
+ "In this simulation, you play the part of robot. Your task is to
+complete the simulation by finding kitten, as is your destiny, and indeed your
+wont. You (robot) are represented by the # character, and you move around with
+the arrow keys touching things. If the thing you touch is kitten, you get a
+cute little animation (which was cuter in the DOS version) and the simulation
+ends. Otherwise, you get a brief description of what it is you touched.")
+ (home-page "http://robotfindskitten.org/")
+ (license license:gpl2+)))
+
(define-public roguebox-adventures
(package
(name "roguebox-adventures")
base-commit: 18119fe288166ff480ca27a1351b09e9c31c1463
--
2.34.0