diff mbox series

[bug#67198] gnu: Add emacs-adwaita-dark-theme

Message ID 0e781a8a92a4ac67cb659643c2a5a42acc0b9e87.1700051896.git.tristan@cott.am
State New
Headers show
Series [bug#67198] gnu: Add emacs-adwaita-dark-theme | expand

Commit Message

Tristan Cottam Nov. 15, 2023, 12:38 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-adwaita-dark-theme): New variable.

Change-Id: Id6e6d0d6aa27e7c1cc6ec0fc11c3a5f09231d751
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: bd0f2173210416e86281c1de8789e7cdab66dd57
prerequisite-patch-id: 5e36e77f4fa1848dbd20c2e5d5cec31d2473c2a8

Comments

Nicolas Goaziou Nov. 15, 2023, 5:11 p.m. UTC | #1
Hello,

Tristan Cottam via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-adwaita-dark-theme): New variable.

Thank you.

> +(define-public emacs-adwaita-dark-theme
> +  (let ((commit "a97d5d5f5657a52c3b4c4b146b4d307dfb1a7a74")
> +        (revision "0"))
> +    (package
> +      (name "emacs-adwaita-dark-theme")
> +      (version (git-version "1.1.0" revision commit))

The last commit is actually a version bump to "1.1.1", so you can bind
`version' to "1.1.1", drop `revision' and use that commit instead.

> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://gitlab.com/jessieh/adwaita-dark-theme")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                  "0g8fjqmz805fhqspbzmpvb90kpzwigl4z56bkykywgy2cwb9ljzh"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://gitlab.com/jessieh/adwaita-dark-theme")
> +      (synopsis "Adwaita-inspired dark color scheme for Emacs")
> +      (description
> +       "adwaita-dark-theme is an Adwaita-inspired dark color scheme for
> +Emacs.")

Nitpick: "Adwaita Dark is an Adwaita-inspired…"

Otherwise, LGTM.

Regards,
Liliana Marie Prikler Nov. 15, 2023, 6:40 p.m. UTC | #2
Am Mittwoch, dem 15.11.2023 um 13:38 +0100 schrieb Tristan Cottam:
> * gnu/packages/emacs-xyz.scm (emacs-adwaita-dark-theme): New
> variable.
> 
> Change-Id: Id6e6d0d6aa27e7c1cc6ec0fc11c3a5f09231d751
> ---
>  gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index be7ffd1f37..b0c5f10b96 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -1995,6 +1995,29 @@ (define-public emacs-suneater-theme
>  theme but now takes more inspiration from the Nano theme.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-adwaita-dark-theme
> +  (let ((commit "a97d5d5f5657a52c3b4c4b146b4d307dfb1a7a74")
> +        (revision "0"))
> +    (package
> +      (name "emacs-adwaita-dark-theme")
> +      (version (git-version "1.1.0" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url
> "https://gitlab.com/jessieh/adwaita-dark-theme")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                 
> "0g8fjqmz805fhqspbzmpvb90kpzwigl4z56bkykywgy2cwb9ljzh"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://gitlab.com/jessieh/adwaita-dark-theme")
> +      (synopsis "Adwaita-inspired dark color scheme for Emacs")
> +      (description
> +       "adwaita-dark-theme is an Adwaita-inspired dark color scheme
> for
> +Emacs.")
Don't start a description with lower case.  If you really need to, use
@code or similar (discouraged here imho), otherwise good ol' "This
package provides" has your back.
> +      (license license:gpl2+))))
> +
>  (define-public emacs-treepy
>    (package
>      (name "emacs-treepy")
> 
> base-commit: bd0f2173210416e86281c1de8789e7cdab66dd57
> prerequisite-patch-id: 5e36e77f4fa1848dbd20c2e5d5cec31d2473c2a8
Cheers
Liliana Marie Prikler Nov. 15, 2023, 6:41 p.m. UTC | #3
Am Mittwoch, dem 15.11.2023 um 18:11 +0100 schrieb Nicolas Goaziou:
> Hello,
> 
> Tristan Cottam via Guix-patches via <guix-patches@gnu.org> writes:
> 
> > * gnu/packages/emacs-xyz.scm (emacs-adwaita-dark-theme): New
> > variable.
> 
> Thank you.
> 
> > +(define-public emacs-adwaita-dark-theme
> > +  (let ((commit "a97d5d5f5657a52c3b4c4b146b4d307dfb1a7a74")
> > +        (revision "0"))
> > +    (package
> > +      (name "emacs-adwaita-dark-theme")
> > +      (version (git-version "1.1.0" revision commit))
> 
> The last commit is actually a version bump to "1.1.1", so you can
> bind `version' to "1.1.1", drop `revision' and use that commit
> instead.

If it's not a release commit, I'd still use git-version.

Cheers
Nicolas Goaziou Nov. 15, 2023, 8:07 p.m. UTC | #4
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Mittwoch, dem 15.11.2023 um 18:11 +0100 schrieb Nicolas Goaziou:

>> The last commit is actually a version bump to "1.1.1", so you can
>> bind `version' to "1.1.1", drop `revision' and use that commit
>> instead.
>
> If it's not a release commit, I'd still use git-version.

FWIW, changing the Version keyword in the header is a release. Also, it
has the benefit of making the version number more meaningful.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index be7ffd1f37..b0c5f10b96 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1995,6 +1995,29 @@  (define-public emacs-suneater-theme
 theme but now takes more inspiration from the Nano theme.")
     (license license:gpl3+)))
 
+(define-public emacs-adwaita-dark-theme
+  (let ((commit "a97d5d5f5657a52c3b4c4b146b4d307dfb1a7a74")
+        (revision "0"))
+    (package
+      (name "emacs-adwaita-dark-theme")
+      (version (git-version "1.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/jessieh/adwaita-dark-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0g8fjqmz805fhqspbzmpvb90kpzwigl4z56bkykywgy2cwb9ljzh"))))
+      (build-system emacs-build-system)
+      (home-page "https://gitlab.com/jessieh/adwaita-dark-theme")
+      (synopsis "Adwaita-inspired dark color scheme for Emacs")
+      (description
+       "adwaita-dark-theme is an Adwaita-inspired dark color scheme for
+Emacs.")
+      (license license:gpl2+))))
+
 (define-public emacs-treepy
   (package
     (name "emacs-treepy")