[bug#77382,rust-team,08/18] gnu: Add rust-faster-hex-0.10.

Message ID 0e5d26a36468149ce819dca2015eaf08fb854968.1743337577.git.gabrielsantosdesouza@disroot.org
State New
Headers
Series gnu: Add matugen. |

Commit Message

Gabriel Santos March 30, 2025, 12:26 p.m. UTC
  * gnu/packages/crates-io.scm (rust-faster-hex-0.10): New variable.
(rust-faster-hex-0.9): Inherit.

Change-Id: I225e83049414cd9fca5e2066fe7f8f4fbded25da
---
 gnu/packages/crates-io.scm | 31 ++++++++++++++++++++++++++-----
 1 file changed, 26 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 077ce6ad07..d5395b1df5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26785,8 +26785,33 @@  (define-public rust-fast-float-0.2
     (description "This package provides a fast floating-point number parser.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-faster-hex-0.10
+  (package
+    (name "rust-faster-hex")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "faster-hex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0wzvv4a1czxfxmh99cza2y0jps97hm3k1j6r6cs816qp5wnsw8vj"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-bytes" ,rust-bytes-1)
+                                   ("rust-criterion" ,rust-criterion-0.5)
+                                   ("rust-heapless" ,rust-heapless-0.8)
+                                   ("rust-hex" ,rust-hex-0.3)
+                                   ("rust-rustc-hex" ,rust-rustc-hex-1))))
+    (home-page "https://github.com/NervosFoundation/faster-hex")
+    (synopsis "Fast hex encoding")
+    (description "Fast hex encoding.")
+    (license license:expat)))
+
 (define-public rust-faster-hex-0.9
   (package
+    (inherit rust-faster-hex-0.10)
     (name "rust-faster-hex")
     (version "0.9.0")
     (source
@@ -26805,11 +26830,7 @@  (define-public rust-faster-hex-0.9
                                    ("rust-proptest" ,rust-proptest-1)
                                    ("rust-rustc-hex" ,rust-rustc-hex-1)
                                    ("rust-serde" ,rust-serde-1)
-                                   ("rust-serde-json" ,rust-serde-json-1))))
-    (home-page "https://github.com/NervosFoundation/faster-hex")
-    (synopsis "Fast hex encoding")
-    (description "Fast hex encoding.")
-    (license license:expat)))
+                                   ("rust-serde-json" ,rust-serde-json-1))))))
 
 (define-public rust-faster-hex-0.8
   (package