From bb5ac4780ddde253c03267550f2930f57d350c44 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Mon, 16 Dec 2019 15:33:22 +0100
Subject: [PATCH] gnu: Add polari.
* gnu/packages/gnome.scm (gspell) [native-inputs]: Add gobject-introspection.
(polari): New package.
---
gnu/packages/gnome.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)
@@ -44,6 +44,7 @@
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2019 Leo Prikler <leoprikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8167,6 +8168,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
("iso-codes" ,iso-codes)))
(native-inputs
`(("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)
@@ -8966,3 +8968,58 @@ tile-matching game Mahjong. It features multiple board layouts, tile themes,
and a high score table.")
(home-page "https://wiki.gnome.org/Apps/Mahjongg")
(license license:gpl2+)))
+
+(define-public polari
+ (package
+ (name "polari")
+ (version "3.32.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version)
+ "/polari-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0h0w9j3y067l911gpj446b3a2w1i2vzr1w2a7cz7i5rhn6qkf2sp"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson/meson-postinstall.sh"
+ (("gtk-update-icon-cache") (which "true")))
+ #t))
+ (add-after 'glib-or-gtk-wrap 'wrap-typelib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/polari")))
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (inputs
+ `(("glib" ,glib)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("gjs" ,gjs)
+ ("libsecret" ,libsecret)
+ ("libsoup" ,libsoup)
+ ("telepathy-glib" ,telepathy-glib)
+ ("telepathy-logger" ,telepathy-logger)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (propagated-inputs
+ `(("telepathy-idle" ,telepathy-idle)
+ ("telepathy-mission-control" ,telepathy-mission-control)))
+ (synopsis "Simple IRC Client")
+ (description
+ "Polari is a simple Internet Relay Chat (IRC) client that is designed to
+integrate seamlessly with the GNOME desktop.")
+ (home-page "https://wiki.gnome.org/Apps/Polari")
+ (license license:gpl2+)))
--
2.24.1