diff mbox series

[bug#41593,1/1] gnu: python-furl: Update to 2.0.0.

Message ID 0e209009-8d51-4f26-9292-6d797f091c27@www.fastmail.com
State Accepted
Headers show
Series [bug#41593,1/1] gnu: python-furl: Update to 2.0.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hamzeh Nasajpour May 29, 2020, 7:40 a.m. UTC
* gnu/packages/python-web.scm (python-furl): Update to 2.0.0.
---
 gnu/packages/python-web.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Marius Bakke May 30, 2020, 2:11 p.m. UTC | #1
"Hamzeh Nasajpour" <h.nasajpour@pantherx.org> writes:

> * gnu/packages/python-web.scm (python-furl): Update to 2.0.0.

This forgot to mention the new input.

[...]

> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index cd8ce8a83f..a7892b02ce 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -324,17 +324,18 @@ over a different origin than that of the web application.")
>  (define-public python-furl
>    (package
>      (name "python-furl")
> -    (version "0.5.6")
> +    (version "2.0.0")
>      (source
>        (origin
>          (method url-fetch)
>          (uri (pypi-uri "furl" version))
>          (sha256
>            (base32
> -            "0lzpfpm686hvz3sr1mcrnd1b3lgmnw8v59gb43wfi98r3b671pqc"))))
> +            "1v2lakx03d5w8954a39ki44xv5mllnq0a0avhxykv9hrzg0yvjpx"))))
>      (build-system python-build-system)
>      (propagated-inputs
> -     `(("python-six" ,python-six)
> +     `(("python-flake8" ,python-flake8)
> +       ("python-six" ,python-six)

I moved python-flake8 to 'native-inputs' because it is only used for
tests according to setup.py.  I also removed the pycodestyle input,
which had been removed in favor of flake8.

Applied!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cd8ce8a83f..a7892b02ce 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -324,17 +324,18 @@  over a different origin than that of the web application.")
 (define-public python-furl
   (package
     (name "python-furl")
-    (version "0.5.6")
+    (version "2.0.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "furl" version))
         (sha256
           (base32
-            "0lzpfpm686hvz3sr1mcrnd1b3lgmnw8v59gb43wfi98r3b671pqc"))))
+            "1v2lakx03d5w8954a39ki44xv5mllnq0a0avhxykv9hrzg0yvjpx"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-six" ,python-six)
+     `(("python-flake8" ,python-flake8)
+       ("python-six" ,python-six)
        ("python-orderedmultidict" ,python-orderedmultidict)))
     (native-inputs
      `(("python-pycodestyle" ,python-pycodestyle)))