[bug#78090,v2] gnu: sshguard: Update to 2.5.0.
Commit Message
* gnu/packages/admin.scm (sshguard): Update to 2.5.0.
[arguments]: Add a phase.
Change-Id: I774ef37069ded85412e55a9d83f76bc989ff8ec3
---
Hi,
This revision adds support for specifying configuration through an
environment variable, as right now configuration path is hardcoded,
making it unusable.
gnu/packages/admin.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)
base-commit: 97ea59b846c5267098a019f36c84dcaa55fb123e
@@ -72,7 +72,7 @@
;;; Copyright © 2024 nathan <nathan_mail@nborghese.com>
;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
-;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2024, 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;; Copyright © 2025 Dariqq <dariqq@posteo.net>
;;; Copyright © 2024 nik gaffney <nik@fo.am>
@@ -6770,7 +6770,7 @@ (define-public rdfind
(define-public sshguard
(package
(name "sshguard")
- (version "2.4.3")
+ (version "2.5.0")
(source
(origin
(method git-fetch)
@@ -6779,10 +6779,20 @@ (define-public sshguard
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1dkijr287zpwdz1bjdchxzmwf1sk6vzpkycz1skm25lkaba6nd9r"))))
+ (base32 "07hwbc6p29nnc5pgcdd3x5x0mry3l7d8ls8zq4yjpy35whs3l29f"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake bison flex python-docutils))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; patch sshguard to find configuration through
+ ;; environment variable
+ (add-after 'unpack 'patch-sshguard
+ (lambda _
+ (substitute* "src/sshguard.in"
+ (("^config=.*$")
+ "config=${SSHGUARD_CONFIG_FILE:-@sysconfdir@/sshguard.conf}\n")))))))
(home-page "https://sshguard.net/")
(synopsis "Daemon to blocks SSH brute-force attacks")
(description